2008 750 carb/fuel guage issues. - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-10-2017, 07:31 AM Thread Starter
Newbie
 
Join Date: Jun 2013
Posts: 13
 
2008 750 carb/fuel guage issues.

My problems lie with my recently acquired 2008 Teryx 750. I have found out that the choke plates are not moving when the choke is pushed in, they seem to be stuck closed causing a very rich fuel condition. I'm not sure what or where to lube as I haven't messed with small engines (stick to automotive engines). Also my fuel gauge doesn't seem to work 99% of the time. I know the Brutes and Teryx use many of the same parts so I'm hoping someone with some experience with either can help me.






Thanks
Wes
Wes13 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-10-2017, 08:37 AM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 6,913
           
I didn't know the 08 Teryx still had carbs...but..I would expect they have the same Kiehins the Brute do so they are plungers that either allows or not allows fuel to be pulled straight from the bowel. The cable pulls these plunders open which opens that port to the vacuum from the intake camber. So..they..or one may be stuck in it's open position. Very common as the spring rusts. Just follow the cables to the carbs, pull the retainer screws out, shoot some WD in there to loosen and slide it all out, clean it up, flush out the tube with WD and reinstall. Might have to replace the springs though.


The rest of your problem must be electrical so look for corroded connections first.

06 BF 750 (Silver)
EZ-Steer EPS | Elka Stage-3s | 26" Grim Reapers on 14" SS112s | Dynatek CDI | Twin Air Filter | TPI Adjustable Airbox Valves | YFZ Catch Can Mod | Perma-Cool Oil Cooler | Diamond "G" Tie Rods w/Moose Ends | EPI Pink Primary W/ Almond Secondary | PowerMadd Handguards & Mirrors | Energy Swaybar Bushings | OMI Stem Bushing | 2013 a-arms & bushings | 2012 Seat | Ricochet Armor | HL Front Bumper | Direction2 Overfenders | Moose Dual Gasser Throttle

15 ZForce 800

NMKawierider is offline  
post #3 of 3 Old 03-10-2017, 09:40 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,122
Images: 77
         
Yeah the Teryx didnt get EFI until the next year. The 08's still had carbs.


MIMB - The REAL "Brute Central"


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Brute Force Wierd Issue noheadscrews Kawasaki 2 11-14-2016 07:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome