Winch mount question... - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-13-2017, 03:39 PM Thread Starter
Newbie
 
Join Date: Aug 2012
Posts: 18
 
Winch mount question...

I'm thinking about buying a KFI winch to replace my Viper winch that's already there. Do I HAVE to buy the KFI mount or will it bolt up to the one already on the machine?
gunner1 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-14-2017, 07:25 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,122
Images: 77
         
Tough question. I've never even heard of KFI. Are you not happy with the Viper?


MIMB - The REAL "Brute Central"


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
post #3 of 4 Old 06-14-2017, 02:04 PM Thread Starter
Newbie
 
Join Date: Aug 2012
Posts: 18
 
Quote:
Originally Posted by Polaris425 View Post
Tough question. I've never even heard of KFI. Are you not happy with the Viper?
You've never heard of KFI?? You're just pulling my leg, right? The Viper winch was fine. It worked every time I needed it and did what I wanted it to do. It's just that their method of attaching the cable to the drum is a pain in the butt to deal with when winter comes because I use my ATV to plow so I like to use either a short synthetic line or a piece of a 2" wide ratchet strap. At least with the KFI, I'm pretty sure that the line is bolted to the hub which would make my job that much easier.

SE35 KFI Stealth Winch - KFI ATV Winch, Mounts and Accessories
gunner1 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 06-15-2017, 07:30 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,122
Images: 77
         
nope never heard of them. But I have been out of the game for a few years now....

I think most winches are standard on their bolt locations. I guess there's not but one way to find out though. lol


MIMB - The REAL "Brute Central"


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
warn winch rope/cable replacement lithod02 Mud Pit 1 04-06-2017 07:22 AM
2008 Brute question xtreme02gt Kawasaki 6 12-12-2016 07:13 AM
winch and fan stopped working on brute force? help? Bf750 Chad Kawasaki 4 03-02-2016 08:02 PM
wheel spacers question for ones that have had them slinger400 Tire/Rim 411 2 02-25-2016 03:59 PM
New to can am, snorkle question Palmettosc Can-Am/BRP 0 01-15-2016 03:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome