MudInMyBlood Forums
Go Back   MudInMyBlood Forums > Brand Basics > Kawasaki

Reply
 
LinkBack Thread Tools Display Modes
Old 10-18-2010, 09:15 AM   #1
Blood, Sweat, and Beers!
 
gpinjason's Avatar
 

Join Date: Nov 2009
Location: Deer Park, TX
Posts: 2,010
gpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the rough
Send a message via Yahoo to gpinjason
Oil light flashing??

What exactly does the flashing oil light indicate? Mine started flashing Saturday after I went through the big water holes to clean the mud out from under the Brute... after a few minutes, all the water dried on the engine and it quit blinking... I'm hoping it's just an electrical connection getting wet... when it first started blinking, I shut it off and checked the oil and everything looked good... and I know the temperature indicator is actually on the display, and it wasn't blinking...

Anyone have any suggestions? Is it just electrical? I need to get in there and re-dielectric grease everything again...








__________________________
New Family ride: 2013 Ranger 900XP
28" EFX Moto MTC's wrapped around 14" MSA M20 Kores
Custom snorkels - Click here for How To!
gpinjason is offline  
Feedback: (1)
Reply With Quote Go to top
Old 10-18-2010, 10:53 AM   #2
Moderator
 
NMKawierider's Avatar
 

Join Date: Apr 2009
Location: NM
Posts: 5,963
NMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of light
Probably just a wet connection. If it had lost pressure, it would be on solid.








__________________________
06 BF 750 (Silver)
EZ-Steer EPS | Elka Stage-3s | 26" Grim Reapers on 14" SS112s | Dynatek CDI | Twin Air Filter | TPI Adjustable Airbox Valves | YFZ Catch Can Mod | Perma-Cool Oil Cooler | Diamond "G" Tie Rods w/Moose Ends | EPI Pink Primary W/ Almond Secondary | PowerMadd Handguards & Mirrors | Energy Swaybar Bushings | OMI Stem Bushing | 2013 a-arms & bushings | 2012 Seat | Ricochet Armor | HL Front Bumper | Direction2 Overfenders | Moose Dual Gasser Throttle

NMKawierider is offline  
Feedback: (0)
Reply With Quote Go to top
Old 10-18-2010, 10:54 AM   #3
Account Disabled
 

Join Date: Feb 2010
Location: Dayton, Tx
Posts: 3,741
Images: 31
filthyredneck is a jewel in the roughfilthyredneck is a jewel in the roughfilthyredneck is a jewel in the rough
I always thought the oil light is for the oil level... if it gets too low, I would think it would trigger it to come on. Have to consult the manual to verify though. My old SRA would flash the oil light & reverse light when I'd go deep with it. Havnt had anything but the reverse light come on with this bike though.
filthyredneck is offline  
Feedback: (15)
Reply With Quote Go to top
Old 10-18-2010, 12:52 PM   #4
Blood, Sweat, and Beers!
 
gpinjason's Avatar
 

Join Date: Nov 2009
Location: Deer Park, TX
Posts: 2,010
gpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the rough
Send a message via Yahoo to gpinjason
last time out my reverse light came on when I hit the water... this time the oil light... I sealed off the reverse light plug with dielectric grease and a little silicone...

I checked the oil and it was slightly below the full mark, but that was as soon as I shut it off, so I'm sure oil was still in the top end draining back down...








__________________________
New Family ride: 2013 Ranger 900XP
28" EFX Moto MTC's wrapped around 14" MSA M20 Kores
Custom snorkels - Click here for How To!
gpinjason is offline  
Feedback: (1)
Reply With Quote Go to top
Old 10-18-2010, 01:00 PM   #5
Rollin' Deep
 

Join Date: Jul 2010
Posts: 265
islandlife is on a distinguished road
the oil light is for pressure. undo the conection for the oil pressure sensor, slap some diletric grease on it and you should be good.








__________________________
06 BF 650 sra, dyna cdi, no KEBC fork, looney tuned duals, xover intakes, polished slides, 26" x 12" mudlights, vision 159's, EPI maroon and black clutch springs, epi front coils, temp guage, fan override, grip/thumb warmers, reverse light, plug wire mod, autometer tach, homemade front bumper and grab bar.


islandlife is offline  
Feedback: (0)
Reply With Quote Go to top
Old 10-18-2010, 01:42 PM   #6
Blood, Sweat, and Beers!
 
gpinjason's Avatar
 

Join Date: Nov 2009
Location: Deer Park, TX
Posts: 2,010
gpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the rough
Send a message via Yahoo to gpinjason
Quote:
Originally Posted by islandlife View Post
the oil light is for pressure. undo the conection for the oil pressure sensor, slap some diletric grease on it and you should be good.
Where exactly is the sensor? I wanna make sure I don't miss it... tried looking for it in the service manual and couldn't find it..








__________________________
New Family ride: 2013 Ranger 900XP
28" EFX Moto MTC's wrapped around 14" MSA M20 Kores
Custom snorkels - Click here for How To!
gpinjason is offline  
Feedback: (1)
Reply With Quote Go to top
Old 10-18-2010, 01:48 PM   #7
Blood, Sweat, and Beers!
 
gpinjason's Avatar
 

Join Date: Nov 2009
Location: Deer Park, TX
Posts: 2,010
gpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the rough
Send a message via Yahoo to gpinjason
i think I found it... is it right next to the oil filter? looking at the front of the engine, to the right of the filter?








__________________________
New Family ride: 2013 Ranger 900XP
28" EFX Moto MTC's wrapped around 14" MSA M20 Kores
Custom snorkels - Click here for How To!
gpinjason is offline  
Feedback: (1)
Reply With Quote Go to top
Old 10-18-2010, 03:08 PM   #8
Rollin' Deep
 

Join Date: Jul 2010
Posts: 265
islandlife is on a distinguished road
yup, just a single wire. blue or purple or something like that








__________________________
06 BF 650 sra, dyna cdi, no KEBC fork, looney tuned duals, xover intakes, polished slides, 26" x 12" mudlights, vision 159's, EPI maroon and black clutch springs, epi front coils, temp guage, fan override, grip/thumb warmers, reverse light, plug wire mod, autometer tach, homemade front bumper and grab bar.


islandlife is offline  
Feedback: (0)
Reply With Quote Go to top
Old 10-19-2010, 05:13 AM   #9
Professional Mudder
 
drtj's Avatar
 

Join Date: May 2009
Location: Tifton Ga
Posts: 1,019
drtj is on a distinguished road
mine started flashing at me once when i was doing a wheelie. I think i ran it up on the back rack & it stayed there a few seconds then it came on. turned it off put it on all 4's checked oil it was fine. started it back up no more problems. hope its just a connection








__________________________
06 750 Green Brute
29.5 Laws
Red Secondary
Moose Module
MIMB Snorkels
Front and Rear bumper Guards
Custom Dents and Scratches
drtj is offline  
Feedback: (0)
Reply With Quote Go to top
Old 10-19-2010, 05:23 AM   #10
Rather b Dirty than Purty
 
Rack High's Avatar
 

Join Date: Feb 2010
Location: Zephyrhills, Florida
Posts: 388
Rack High will become famous soon enough
Quote:
Originally Posted by drtj View Post
mine started flashing at me once when i was doing a wheelie. I think i ran it up on the back rack & it stayed there a few seconds then it came on. turned it off put it on all 4's checked oil it was fine. started it back up no more problems. hope its just a connection
drtj, wheelies cause the oil to pile up on the backside of the motor away from the oil pump. This triggers the oil light to come on as no oil is being picked up by the pump. If run too long in that condition, you're looking at internal engine damage IMHO.








__________________________
08 Brute Force 750I, VDI Copperhead, HMF Swamp exhaust with custom snorks and radiator relocate. UNI air filter. Pink primary/ red secondary clutch springs and EPI weights. ASR tie rods and ends. 2" lift kit, 30" Zilla rears all the way around on 14" ITP SS212 wheels. Viper Max MX4000# winch with black Amsteel synthetic cable.

TEAM MONEY PIT
Rack High is offline  
Feedback: (0)
Reply With Quote Go to top
Old 10-19-2010, 06:03 AM   #11
Blood, Sweat, and Beers!
 
gpinjason's Avatar
 

Join Date: Nov 2009
Location: Deer Park, TX
Posts: 2,010
gpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the rough
Send a message via Yahoo to gpinjason
Quote:
Originally Posted by drtj View Post
mine started flashing at me once when i was doing a wheelie. I think i ran it up on the back rack & it stayed there a few seconds then it came on. turned it off put it on all 4's checked oil it was fine. started it back up no more problems. hope its just a connection
well, considering the location of the little connector... I'm willing to bet it was from water... it's very low on the front of the engine.. I will be checking everything else out carefully also, but I'm 95% sure it just needs some dielectric grease....

and yes, I know that riding wheelies will cause the oil to run to the back of the engine, but I wasn't riding wheelies either... I just drove through a rack deep hole about 4 or 5 times to clean the mud outta my frame, tires, a-arms...








__________________________
New Family ride: 2013 Ranger 900XP
28" EFX Moto MTC's wrapped around 14" MSA M20 Kores
Custom snorkels - Click here for How To!
gpinjason is offline  
Feedback: (1)
Reply With Quote Go to top
Old 10-19-2010, 06:35 AM   #12
Backwoodz Boggerz
 
rmax's Avatar
 

Join Date: Nov 2009
Location: perkinston ms./ jonesboro ar.
Posts: 1,374
Images: 15
rmax has a spectacular aura aboutrmax has a spectacular aura about
it is a pressure sensor, i put a direct presure gage on mine in line with the electric idle 45lbs- with any rpm added goes to 75lbs wide open 90+lbs. this tells me pressure is directly in time with rpm, an i never thought they would produce those kind of numbers, i have a extra presure guage thet i will do a test on to see what pressure has to be to put light out, an post later








__________________________
06, 650i,sleeved to 85mm fst 11.5/1, fststage 2 cams, intakes polished, ex ports opened up, hl springs, 29.5 laws itp rims,rad relocate with brush guard, 3in center snorkels(home made), wind screen h/m,custom 4 gage cluster (oil temp,oilpress,water temp,an return oil temp), full hmf ex,3000lb warn winch, backup light with brush guard, front mounted recevier hitch,rmax manual 4wd,oilcooler, b/w boston (mud)terrior.had to include he goes everywhere 4 wheeler goes. ez steer by satv
rmax is offline  
Feedback: (3)
Reply With Quote Go to top
Old 10-19-2010, 06:45 AM   #13
Blood, Sweat, and Beers!
 
gpinjason's Avatar
 

Join Date: Nov 2009
Location: Deer Park, TX
Posts: 2,010
gpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the roughgpinjason is a jewel in the rough
Send a message via Yahoo to gpinjason
cool, sounds good








__________________________
New Family ride: 2013 Ranger 900XP
28" EFX Moto MTC's wrapped around 14" MSA M20 Kores
Custom snorkels - Click here for How To!
gpinjason is offline  
Feedback: (1)
Reply With Quote Go to top
Old 10-19-2010, 10:33 PM   #14
Experienced Mudder
 
blue beast's Avatar
 

Join Date: Feb 2010
Location: Poynor,TX
Posts: 837
Images: 25
blue beast is on a distinguished road
guess i need to check these also. i didnt grease them . something else goes on the to do list. check, check








__________________________

08 brute force 750 4x4i
29.5 LAWS/STI HD2se gloss black rims
VFJ #1/#2 springs
2" snorks/ammo cans
3.0 warn winch//Terex belt
temp gauge/fan switch
1"spacers/2" lift
stock exhaust snorked/rad. racked

blue beast is offline  
Feedback: (1)
Reply With Quote Go to top
Old 10-20-2010, 03:08 PM   #15
Moderator
 
NMKawierider's Avatar
 

Join Date: Apr 2009
Location: NM
Posts: 5,963
NMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of lightNMKawierider is a glorious beacon of light
Quote:
Originally Posted by rmax View Post
it is a pressure sensor, i put a direct presure gage on mine in line with the electric idle 45lbs- with any rpm added goes to 75lbs wide open 90+lbs. this tells me pressure is directly in time with rpm, an i never thought they would produce those kind of numbers, i have a extra presure guage thet i will do a test on to see what pressure has to be to put light out, an post later
Hmmm..the book for the 06 750 says with the oil temp at 248 degrees and at 4000 rpm, it should be 62.6 psi and the pressure relief should keep it from going too much higher. I'm thinking if yours is getting to 90+, it might be stuck, which they say does happen. Carefull you don't wash-out a bearing. That's why you don't see too many high pressure pumps any more.








__________________________
06 BF 750 (Silver)
EZ-Steer EPS | Elka Stage-3s | 26" Grim Reapers on 14" SS112s | Dynatek CDI | Twin Air Filter | TPI Adjustable Airbox Valves | YFZ Catch Can Mod | Perma-Cool Oil Cooler | Diamond "G" Tie Rods w/Moose Ends | EPI Pink Primary W/ Almond Secondary | PowerMadd Handguards & Mirrors | Energy Swaybar Bushings | OMI Stem Bushing | 2013 a-arms & bushings | 2012 Seat | Ricochet Armor | HL Front Bumper | Direction2 Overfenders | Moose Dual Gasser Throttle

NMKawierider is offline  
Feedback: (0)
Reply With Quote Go to top
Reply

Bookmarks


Search tags for this page
05 brute force 650 is in limp mode and oil light is flashing
,
05 brute force 650 oil light is blinking and has lost power
,

brute force 750 oil light flashing

,

brute force oil light flashing

,

kawasaki brute force 650 oil light flashing

,
kawasaki brute force 750 oil light flashing
,
kawasaki brute force oil light flashing
,
kawasaki prairie 650 oil light flashing
,
oil light on brute force 750
,
why does the oil light on a 2013 teryx flash
Click on a term to search for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fi light flashing bazookajoe666999 Kawasaki 9 05-31-2013 09:44 AM
FI light flashing big brute Kawasaki 7 04-19-2010 05:49 PM
2/4wheel light flashing?? CreepinDEEP Kawasaki 13 04-14-2010 05:58 PM
2002 650 - Flashing 2x4 / 4x4 light Huntersdad Kawasaki 18 12-28-2009 08:58 PM
Temp light flashing. 08 Twisted10 Kawasaki 46 03-09-2009 02:02 PM


All times are GMT -6. The time now is 01:59 AM.


Powered by The Mighty Kawasaki V-Twin
MudInMyBlood 2006-2011
BFWDP

SEO by vBSEO ©2011, Crawlability, Inc.