HOW TO: Reset Maintenance Codes - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 03-21-2012, 09:42 PM Thread Starter
There's Mud In My Blood
 
Join Date: Feb 2010
Location: Dayton, Tx
Posts: 3,737
Images: 31
     
Post HOW TO: Reset Maintenance Codes

Here is a How-To for manually resetting the "Maintenance Required" code that comes up each time your CanAm is due for maintenance per whats programmed from the factory. This way does not require the BUDS software that the dealer uses, its just a little long winded....but it will save you money unless you just have an awesome dealer that will plug up to the computer for you for free. I got this in the form of a print-out directly from the service manager at my dealer....who just happens to be really cool.

1. ECM must be completely powered down.
2. Transmission in PARK.
3. Turn the Ignition Switch ON.
NOTICE: Engine must NOT be running.

Now the following steps must be done in this order in 4 seconds or less:
1. Press the Override Button.
2. Press the Brake Pedal.
3. Release the Brake Pedal.
4. Release the Override Button.
5. Press the Brake Pedal.
6. Release the Brake Pedal.
7. Press the Override Button.
8. Press the Brake Pedal.
9. Release the Brake Pedal.
10. Release the Override Button.
11. Turn Ignition Switch to OFF and Allow to Power All the Way Down.

NOTE: After turning the ignition switch to OFF, the electrical system stays ON for a moment. Wait till it's completely off.

Next time the ignition switch is turned on the maintenance message will not be displayed. In the event the maintenanc required message is still present or has come back on, do the procedure again.
filthyredneck is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-22-2012, 12:05 AM
Honored Member
 
gpinjason's Avatar
 
Join Date: Nov 2009
Location: Deer Park, TX
Posts: 2,042
       
Send a message via Yahoo to gpinjason
Has it been proven to work yet?


Wasting time, one post at a time... Via Tapatalk for iPhone 4...

New Family ride: 2013 Ranger 900XP
28" EFX Moto MTC's wrapped around 14" MSA M20 Kores
Custom snorkels - Click here for How To!

Project Mini Crawler: 2001 Yamaha Kodiak 400
Full custom miniature rock crawler.. Coming Soon.
View Thread Here!
gpinjason is offline  
post #3 of 9 Old 03-22-2012, 12:10 AM
Trail Rider
 
rewired's Avatar
 
Join Date: Apr 2009
Location: sardis, ms
Posts: 74
 
It works on the commanders.
rewired is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 03-22-2012, 09:53 AM Thread Starter
There's Mud In My Blood
 
Join Date: Feb 2010
Location: Dayton, Tx
Posts: 3,737
Images: 31
     
Quote:
Originally Posted by gpinjason View Post
Has it been proven to work yet?
It was a print-out that was distributed to the dealer from CanAm/BRP..... I do not know if it works for all years or only the newer ones, I did notice just now on the bottom of the printout it says "2011-12 SERVICE" ....so maybe it only works for the brand new ones, but it can't hurt to try on any of them if it saves a trip to the dealer. The service manager and the guy in the shop that reset my code both said it works, but occasionally you have to do it more than once.

*The paper even says "Please make sure to communicate this information to your customer." I just figured it would be a great addition to the little CanAm info we have here.
filthyredneck is offline  
post #5 of 9 Old 03-22-2012, 10:16 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,121
Images: 77
         
Thanks for sharing


MIMB - The REAL "Brute Central"


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
post #6 of 9 Old 03-22-2012, 11:32 AM Thread Starter
There's Mud In My Blood
 
Join Date: Feb 2010
Location: Dayton, Tx
Posts: 3,737
Images: 31
     
Anytime...hopefully I get some good stuff in this section since we don't have much. Give me some time lol, I'll be waist deep in this bike soon
filthyredneck is offline  
post #7 of 9 Old 03-22-2012, 11:46 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,121
Images: 77
         
Counting on you!


MIMB - The REAL "Brute Central"


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
post #8 of 9 Old 03-22-2012, 02:40 PM
Newbie
 
boostedagain's Avatar
 
Join Date: Aug 2009
Location: Brevard County Florida
Posts: 23
 
does not work on older ones, just tried my 08 gade a few times, did not work on it...

08 Gade
exhaust/ programmer
30" silverbacks
gorilla bumper
boostedagain is offline  
post #9 of 9 Old 03-22-2012, 03:58 PM Thread Starter
There's Mud In My Blood
 
Join Date: Feb 2010
Location: Dayton, Tx
Posts: 3,737
Images: 31
     
That sucks... Hopefully it will still help the newer bikes, I know it works on a commander, friend of mine had to do it.
filthyredneck is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Codes on a 2009 800 Touring KMKjr Polaris 1 03-02-2012 11:23 PM
NEW VDI copperhead, trouble with error codes.. 88rxn/a Kawasaki 63 11-30-2011 06:06 PM
Chinese ATV Maintenance robisra All Other Brands 5 10-21-2011 11:05 AM
Scheduled Maintenance - 9/8/2011 phreebsd Site News 4 09-08-2011 07:54 AM
Can-Am Diagnostics-Fault Codes TorkMonster "How-To's" 4 09-03-2010 06:01 PM

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome