Is this bad for engine? - MudInMyBlood Forums
WBM Engines

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-09-2018, 12:33 PM Thread Starter
Sponsor
 
nFlow's Avatar
 
Join Date: Aug 2010
Posts: 254
 
Is this bad for engine?

Here is a picture of an engine we recently received at nFLOW Remanufactured Engines with a connecting rod that tried to exit through the oil filter casting! Give us a call for all of your engine, transmission and turbocharger reman needs! You can reach us at 812-402-8282. Remanufactured Engines | High Quality | Free & Fast Shipping | nFLOW
Attached Thumbnails
Click image for larger version

Name:	connecting rod through oil casting.jpg
Views:	16
Size:	62.2 KB
ID:	19790  


Visit our website at: www.nflowmotorsports.com
or
Like us on Facebook at: https://www.facebook.com/pages/NFLOW/237263726448384
nFlow is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome