Fan on Teryx won't turn off - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-17-2010, 07:10 PM Thread Starter
Trail Rider
 
big brute's Avatar
 
Join Date: Apr 2009
Location: shreveport la
Posts: 76
 
Fan on Teryx won't turn off

I've seen all the problems that everyone is having about the fan not coming on and overheating but mine won't turn off.When it gets hot enough for the fan to come on it will stay on all day,I have to go under the seat and unplug it at the breaker.It's still under warranty,think it's worth taking it back up there or just putting a switch on it.I've been told that the temp. switch may be bad..

08 brute snorkeled 29.5 swamp lites on black SS wheels HMF exhaust 2 in. lift kit***05 FOREMAN 28" OUTLAW M/S/T HIGHLITHER LIFT AND SRPINGS***2000 HONDA 300 27" OUTLAW M/S/T HIGHLIFTER LIFT AND SPRINGS***08 Teryx 28" swamplites on black ss wheels
big brute is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-17-2010, 07:24 PM
Trail Rider
 
Join Date: Mar 2010
Posts: 87
 
i would just bypass it and put a temp guage in it
duramaxlover is offline  
post #3 of 4 Old 03-17-2010, 08:25 PM
Experienced Mudder
 
Guarino113's Avatar
 
Join Date: Oct 2009
Location: Kenbridge, VA
Posts: 733
 
Send a message via AIM to Guarino113 Send a message via Yahoo to Guarino113
i had that problem with my father in laws. someone on here told me to hit the sensor on the radiator so i did and it went off and havent had any more problems with it.

2007 Kawasaki Brute Force 750i
29.5" Laws 10s and 12s On ITP Type 5 Wheels
2" Lift And 1.5" Spacers
Moose Module, K&N Air Filter W/O Screen
3000 Pound Xtreme Winch/ Amsteel Blue Rope
Dynojet Jet Kit 142F/148R Needle On 4th Notch
MIMB Snorkels And Exhaust Snorkel
Almond primary/ Lime Green Secondary
Radiator Relocate W/Temp Gauge And Fan Switch
6K 50 W HID's, 1 Watt Blue LED's, Horn
[SIGPIC][/SIGPIC]
Guarino113 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 03-25-2010, 08:28 AM
There's Mud In My Blood
 
Join Date: Feb 2010
Location: Dayton, Tx
Posts: 3,737
Images: 31
     
My 07 Brute's fan used to do the same exact thing...come to find out the actual breaker was bad, just unplugged it and plugged in a 15amp fuse in its place. (This was per Highlands Kawasaki and requires NO CUTTING and it didnt void my warranty) and it fixed my problem. My 08 has the fuse plus the switch mod and have zero issues with it.
filthyredneck is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wont Turn Over parkerexpress Kawasaki 17 02-26-2010 05:47 PM
2008 teryx fan stayin on Guarino113 SxS Playground 2 11-27-2009 11:27 AM
rode through mud, now handle shakes and hard to turn - why!? mystical_ice Kawasaki 20 11-21-2009 05:27 PM
When it's time to turn in one's drivers license cojack Mud Pit 9 09-11-2009 07:59 AM
Teryx Snork phreebsd SxS Playground 15 08-09-2009 10:14 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome