08 Brute force 750I - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-27-2018, 05:31 PM Thread Starter
Newbie
 
Join Date: Oct 2018
Posts: 1
 
08 Brute force 750I

Hi Everyone I am new here and I am on a 2008 Brute force 750injected . I got it very cheap because it is stuck in limp home mode and the belt light is flashing…The four wheeler only has 170 hours on it and 1000 miles on it I already checked the bell switch to make sure it is in the on position and there is absolutely no gray and black connector under the seat or a red jumper wire to reset the belt can anyone please help me?
Billy Covell is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-28-2018, 08:08 AM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,248
           
The jumper connector has to be under the seat...however the jumper cap itself make be lost and you can still buy those from any parts house. On BC (Brute Central) we have a section called Brute technical articles. Basically the "How Tos". In it are several ways to reset that belt light. You can also make your own jumper and follow the books reset procedure.



Here's a link...cause we are all family now.



Brute Technical Articles

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #3 of 3 Old 11-01-2018, 07:08 AM
Trail Rider
 
drewski1126's Avatar
 
Join Date: Jan 2018
Posts: 45
 
This is from the manual. 08 Brute force 750I-img_1796.jpg


Sent from my iPhone using Tapatalk
drewski1126 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Brute Force Popping and Sputtering DanOMite Kawasaki 9 09-20-2018 10:09 AM
2011 Brute Force 750i Issues tonyb443 Kawasaki 5 03-20-2018 07:44 PM
2008 Brute Force 750 fuel relay troubleshooting ian.macmillan Kawasaki 5 10-12-2017 10:04 AM
08 brute force 750 help needed! Kawi gang Kawasaki 14 02-27-2016 07:29 AM
brute force eating belts help ryanharrington827 General Tech. & Audio Info. 6 02-11-2016 05:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome