Kawasaki brute force 750 09 issue - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-02-2018, 12:05 PM Thread Starter
Newbie
 
Join Date: Oct 2018
Posts: 0
 
Kawasaki brute force 750 09 issue

So i was riding my 09 brute today then it started backfiring and lagging i parked it then turned it off , afterwards i tryed to turn it on and it didnt after waiting more i tryed again and it turned on but the rpm is very very low it can hardly rev and when i put a gear and try to move it it turns off instantly.
Any idea of what can be causing the issue?
Marc moukarzel is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-02-2018, 08:31 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,292
           
It's either a fuel supply issue, low electrical power to the coils...or a valve timing issue. All easy enough to check with the manual.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #3 of 3 Old 11-08-2018, 05:37 PM
Newbie
 
Rcallesto's Avatar
 
Join Date: Nov 2018
Posts: 0
 
Is the belt light on and flashing ? If so you may have gone into limp mode.
Rcallesto is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kawasaki Brute Force 300 clutch Capatina Stefan Kawasaki 3 07-04-2018 06:58 PM
Brute force diff issue!! Bruteforce75019 Kawasaki 1 03-02-2017 10:04 AM
2010 Kawasaki Brute Force 750 doesn't have full power Broke_Force Kawasaki 7 01-18-2017 07:40 PM
2008 Brute Force Wierd Issue noheadscrews Kawasaki 2 11-14-2016 08:43 PM
carb jetting kawasaki brute force help burns1986 Kawasaki 4 04-18-2016 02:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome