hope someone can help me! - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-11-2014, 08:29 PM Thread Starter
Newbie
 
Join Date: Jun 2014
Posts: 1
 
hope someone can help me!

Hello, my name is chris i have a 2013 outlander 650 xmr. currently with a cvtech tribolc clutch when i ordered the clutch i told them i would be running 30" silver backs on 14's rims. I have the proper weight and springs from them... my question is i find that it doesn't seem the power is getting to my tires. i have hmf swamp series slip on with their optimizer. Im okay with were the rpms are now in the bike will start moving around 24-2700ish. don't get me wrong its running fine. around 60km/h my rpms are around 5700 something like that. I have the stock secondary, i was reading up how the clutches worked and from what i understand it seems like i may need my secondary to grab a little sooner to help pull away and get my rpms down a little?* any information / suggestions will be help full thank-you for your time**
deveaux208 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I hope this is BS Josh82 Across the Web 6 04-19-2013 10:42 AM
Hope this isn't true LSU Polaris425 Mud Pit 1 03-03-2013 07:05 AM
Hope this was a miss print!! sloboy SxS Playground 20 06-01-2012 05:00 PM
I hope I didn't get this guy fired The Big Bad Wolf Mud Pit 17 04-25-2012 08:15 PM
Hope our TEXAS members are ok! phreebsd Mud Pit 17 04-04-2012 03:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome