Kawasaki Brute Force 300 clutch - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-03-2018, 01:47 AM Thread Starter
Newbie
 
Join Date: Jul 2018
Posts: 1
 
Kawasaki Brute Force 300 clutch

Hello, I have a Kawasaki Brute Force 300 and I think my clutch belt is slipping. When I try to climb a hill or I try to hit the max speed when the throttle is half way, my rpms goes crazy. I don’t know if the belt or the primary clutch don’t work properly. What can I do to stop these kind of jumping rpms? At how many kilometers do I need to change the belt and primary clutch?
P.S. Sorry for my bad English )
Capatina Stefan is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-03-2018, 06:57 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,279
Images: 77
         
Start by inspecting the belt. If it looks good, check the belt tension/deflection. It could be that the belt has just stretched a little, and you need to remove a shim
from the secondary clutch to tighten it up. We have instructions in the clutching section above on how to do both.


MIMB - The REAL "Brute Central"


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
post #3 of 4 Old 07-04-2018, 01:43 AM
Newbie
 
Join Date: Jun 2018
Posts: 2
 
Took my belt cover over and it looks like I have an oil leak somewhere. All over the clutch was oil. I cleaned the belt, primary and secondary clutch and it works again. Unfortunately I can’t find the oil leak.
stefancapatina is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 07-04-2018, 05:58 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,249
           
Probably the main seal or the transmission's shaft seal. May be easy to replace. About how much do you weigh? Sometimes the load is a factor on the seals.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is online now  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brute force 750 clutch mod question Rhargrove General Tech. & Audio Info. 1 02-17-2017 08:46 AM
2010 Kawasaki Brute Force 750 doesn't have full power Broke_Force Kawasaki 7 01-18-2017 06:40 PM
Brute force clutch problem Bruterider84 Kawasaki 3 04-25-2016 07:02 AM
carb jetting kawasaki brute force help burns1986 Kawasaki 4 04-18-2016 01:52 PM
2012 fuel injected Kawasaki brute force 750 Litenyaup For Sale/Trade 6 03-31-2016 08:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome