Kawasaki Brute Force oil leak fron the clutch - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-02-2018, 03:58 AM Thread Starter
Newbie
 
Join Date: Jun 2018
Posts: 2
 
Kawasaki Brute Force oil leak fron the clutch

I had some belt slip a week ago and I took off the belt cover and all over the clutch was oil. I cleaned the clutch and I reassembled it. It was working fine until yesterday when I filled in with oil in the transmission because the oil level was low ( I put approximately 100mm). After 40km the belt started to slip again. Why the Atv was working fine with the oil level a little bit low?
stefancapatina is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-02-2018, 09:17 AM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,248
           
Quote:
Originally Posted by stefancapatina View Post
I had some belt slip a week ago and I took off the belt cover and all over the clutch was oil. I cleaned the clutch and I reassembled it. It was working fine until yesterday when I filled in with oil in the transmission because the oil level was low ( I put approximately 100mm). After 40km the belt started to slip again. Why the Atv was working fine with the oil level a little bit low?
Because your seal on the shaft is bad. Just replace it. And the Kawasaki V-twim used a shared sump system so the oil from the engine also lubes the transmission...ie same oil. There are seals on both the crank shaft behind the primary and one on the transmission input shaft behind the secondary. Both are easily replaced. But do know those seals don't just start leaking for no reason. It does usually mean there is play developing in that bearing. Of course the seal could have been damaged from a belt shredding apart at some time too.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kawasaki Brute Force 300 clutch Capatina Stefan Kawasaki 3 07-04-2018 05:58 PM
Brute force 750 clutch mod question Rhargrove General Tech. & Audio Info. 1 02-17-2017 08:46 AM
2010 Kawasaki Brute Force 750 doesn't have full power Broke_Force Kawasaki 7 01-18-2017 06:40 PM
Brute force clutch problem Bruterider84 Kawasaki 3 04-25-2016 07:02 AM
carb jetting kawasaki brute force help burns1986 Kawasaki 4 04-18-2016 01:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome