2008 Brute Force Popping and Sputtering - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 09-03-2018, 02:35 PM Thread Starter
Trail Rider
 
DanOMite's Avatar
 
Join Date: Oct 2011
Posts: 49
 
2008 Brute Force Popping and Sputtering

I need some guidance for an issue with my Brute. I've read multiple threads and tried a handful of different things with no success.

Brute info:
2008 Brute Force 750
4372 kms (2716 miles)
311 hours
2" snorkels
Stock exhaust
MSD purchased from VForce John tuned for 2" snorkels & stock exhaust
Catch can mod

Issue:
About 5 months ago the Brute began to pop and sputter from a cold start when starting to ride but it typically goes away after a few minutes, it rarely does this from a cold start. After letting the Brute sit for 20 min It'll start / idle fine but will sputter & pop way worse when I try to ride it. Idle good, 1/3 to 1/2 throttle extreme popping and sputtering, full throttle it'll pop & sputter then take off. When it's popping and sputtering I can hear it from the air box too, it seems to be starved of fuel. This doesn't go away until the Brute sits for extended periods or overnight which tells me it could be related to heat.

What have I tried:
- Fresh gas
- Gas tank checkvalve good, not starving it that way
- Highly suspicious of the fuel pump being an 08 Brute
- Had pump tested at dealership and its pumping 42psi
- Pump screen was dirty and they cleaned it, I thought this was the magic bullet but no
- Throttle positioning sensor checked also by dealer
- I removed MSD and ran stock, problem still exists
- Checked wiring under the seat and fuses

What I suspect:
I suspect the fuel pump could be the culprit seeing how the problem surfaces after the machine reaches running temperatures. The dealer probably ran it for short tests not allowing it to reach operating temperatures. It's still the original fuel pump too. 08s are notorious for having fuel pump issues but I don't want to change it if it could be something else. I'd like to explore all my options before I take the plunge and pay for an overpriced fuel pump.

I love this machine but honestly I feel like pushing it off of a cliff

2008 Brute Force 750i
26" ITP Mud Lite XL
2500lb Warn Winch
VFJ MSD Charge FI
2" Snorkels
Catch Can Mod

Last edited by DanOMite; 09-03-2018 at 06:25 PM.
DanOMite is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 09-03-2018, 07:00 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,249
           
My first assessment would have been the pump too or fuel-related...especially sense it's an 08. But lets check the valves and the throttle body boots for any issues, then lets check the valve timing and compression. If the compression is low, lets do a leak-down test to find what's bad. While at it lets test the voltage- both static and running and..the coil voltage. Lets not forget those peskie fuse boxes- pull it, flip it over and check all the connections underneath. And if all that is good..check the CPS.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #3 of 10 Old 09-03-2018, 08:45 PM Thread Starter
Trail Rider
 
DanOMite's Avatar
 
Join Date: Oct 2011
Posts: 49
 
Thanks NMKawierider, looks like I got some work to do! When I make some progression Iíll update this thread. Many thanks for giving some advise.

2008 Brute Force 750i
26" ITP Mud Lite XL
2500lb Warn Winch
VFJ MSD Charge FI
2" Snorkels
Catch Can Mod
DanOMite is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 09-03-2018, 08:49 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,249
           
Quote:
Originally Posted by DanOMite View Post
Thanks NMKawierider, looks like I got some work to do! When I make some progression Iíll update this thread. Many thanks for giving some advise.
Probably something simple..just finding it is the tough part sometimes.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #5 of 10 Old 09-10-2018, 09:04 PM Thread Starter
Trail Rider
 
DanOMite's Avatar
 
Join Date: Oct 2011
Posts: 49
 
It’s fixed! I thought I’d post what my issue was to help someone else out. I was trying various things but was making no progression. I took it to the shop and they found the issue. My rear plug was constantly being fouled. After changing the plugs the rear would foul up very quickly, the front was fine. They leaned out the rear cylinder and tested with positive results, the rear was no longer being fouled.

The Brute runs like a champ now. I swear I have more power too!
Attached Thumbnails
Click image for larger version

Name:	B1383059-A134-4FC9-87E2-E405F64A2FED_1536634900498.jpeg
Views:	45
Size:	170.7 KB
ID:	19804  

2008 Brute Force 750i
26" ITP Mud Lite XL
2500lb Warn Winch
VFJ MSD Charge FI
2" Snorkels
Catch Can Mod
DanOMite is offline  
post #6 of 10 Old 09-18-2018, 07:26 AM
Newbie
 
ian.macmillan's Avatar
 
Join Date: Sep 2017
Posts: 12
 
Garage
"Leaned out adjuster on rear cylinder"? How do you lean out one cylinder on an EFI bike without changing the fuel mapping?

2008 Kawasaki Brute Force 750i Fuel Injected
ian.macmillan is offline  
post #7 of 10 Old 09-18-2018, 08:10 AM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,249
           
Quote:
Originally Posted by ian.macmillan View Post
"Leaned out adjuster on rear cylinder"? How do you lean out one cylinder on an EFI bike without changing the fuel mapping?
Exactly..not possible to lean one cylinder even through re-mapping....unless you have a controller you can do that with. Probably had a bad/leaking injector.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #8 of 10 Old 09-18-2018, 08:42 PM Thread Starter
Trail Rider
 
DanOMite's Avatar
 
Join Date: Oct 2011
Posts: 49
 
When I picked up the machine they said there was an adjustment in the throttle body, I want paying too much attention though. Next time I take it to Dr. Kawasaki Iíll ask for more details just out of curiosity.

Cheers!

2008 Brute Force 750i
26" ITP Mud Lite XL
2500lb Warn Winch
VFJ MSD Charge FI
2" Snorkels
Catch Can Mod
DanOMite is offline  
post #9 of 10 Old 09-19-2018, 07:40 PM
Trail Rider
 
drewski1126's Avatar
 
Join Date: Jan 2018
Posts: 45
 
Are they referring to the vacuum synchronization lines. I had to adjust mine after I found the guy before me had installed the rear cam in 180 out and the thing was running on one cylinder. He adjusted it to compensate for this issue. The bike was actually running but not at all powerful

Once I got the cam issues resolved I had to undo his adjustment on that Vacuum sync to get it running good again.




Sent from my iPhone using Tapatalk
drewski1126 is offline  
post #10 of 10 Old 09-20-2018, 10:09 AM Thread Starter
Trail Rider
 
DanOMite's Avatar
 
Join Date: Oct 2011
Posts: 49
 
Thanks for the details and pic drewski1126!

2008 Brute Force 750i
26" ITP Mud Lite XL
2500lb Warn Winch
VFJ MSD Charge FI
2" Snorkels
Catch Can Mod
DanOMite is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome