Help with electronics on 650i - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-21-2018, 07:33 PM Thread Starter
Newbie
 
Join Date: Nov 2018
Posts: 1
 
Help with electronics on 650i

Hello all. New to this forum. I recently purchased a 06 BF 650I. I bought it at a good price and was told that it has an intermittent spark issue. I’m an rv tech by trade and been always wrenching away at small engines both 4 and 2 stroke and have rebuilt an in-line 6 motorcycle engine Yamaha. I know my way around engines and atvs but this brute is a different animal to say the least. Anyways I got it home and all plastics are off and have figured out the symptom of spark issue but not the problem. The front cylinder will spark constant but the rear cylinder will only for 3 seconds. I swapped plugs and also the coils and the problem stays with the rear cylinder. I checked the roll over switch “I see that’s a common question people always ask” and I am getting milivolts on the signal wire - so hardly anything. I believe that is correct? I have a secondary ecu and swapped that out and same problem. I then did a continuity test within the power signal wires from rear coil to the igniter box. The igniter box is a dynatek cdi. Hear this is a good one to have. Now I have done more research and can’t find my next answer to a huge question I have!! So I was told when I bought this quad that the original motor was removed and another 650 put in and was from a SRA quad. The bike is an IRS. So I did some looking and the electronics are different between the two? Different part numbers on electronics including the pulse coil which I have tested and the ohm reading is 117 to 118. Now I read that it should be above 417. So I figured it was bad. Great a $80 part and problem fixed. Well when I realized the pulsator coil is different between the two irs vs sra I then found a sra bike cheap with good motor and all electronics and went to go buy it but the guy lied and was a POS. I did test his pulsator coil while I was there and it tested at 114 ohms. Very close to mine so I’m figuring that is correct for the sra motor? So now I’m thinking of this. Please the experienced tech guys on this help me out. Could I just change the stator and pulsator coil on the sra motor to the irs motor and will work with the existing cdi and ecu? I already looked into the crankshaft and they are the exact same so why not? Or would I need to change the ecu and cdi igniter? Would the voltage regulator need to be changed or the generator? Thanks guys. Also any other things I should know about? Sorry for the long post just want you all to know everything up front.
Brutepage08 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brute Force 650i shuts down after 5 sec. marklpenni General Tech. & Audio Info. 5 08-03-2018 07:30 AM
650i owner thinking of moving up to 750 -- looking for opinions/advice Roody Mud Pit 3 10-02-2016 09:13 AM
Brute 650i snorkel rosenj87 Kawasaki 4 09-06-2016 02:02 PM
my 650i rmax ATV Media 1 03-16-2016 07:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome