New to the site with questions!!! - MudInMyBlood Forums
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 Old 02-09-2010, 09:19 PM Thread Starter
Newbie
 
troydorics's Avatar
 
Join Date: Feb 2010
Location: Ellenton, FL
Posts: 13
 
New to the site with questions!!!

First off this places rocks!!!!

ok now on to the questions...

i have a 07 650i Brute

its running like crap... it spits and spudders, backfires like crazy and dosent seem to have as much power as normal. I was thinking about pulling the carbs off and cleaning them and changing the plugs... Just figured i would ask around before tearing into my brute.

Thanks in advance.

Troy
troydorics is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 02-09-2010, 09:20 PM
Wright Guard
 
phreebsd's Avatar
 
Join Date: Dec 2004
Location: Bama
Posts: 6,758
Images: 37
           
welcome to the site!
are you possibly in limp mode?

2008 Kawasaki Teryx
31" Laws
Black ITP SS212's
Relocated Radiator
Maroon Primary
Yellow Secondary
MIMB Snorkels (dual 2" intake)
Rejetted
RaceDriven Sintered Metal Brake Pads
BigGun EVO Exhaust
Viper Max 5000 WideSpool with Amsteel Blue

TEAM ROLLIN' DEEP 2013
phreebsd is offline  
post #3 of 21 Old 02-09-2010, 09:22 PM Thread Starter
Newbie
 
troydorics's Avatar
 
Join Date: Feb 2010
Location: Ellenton, FL
Posts: 13
 
what is limp mode... i am right at 90 hours
troydorics is offline  
Sponsored Links
Advertisement
 
post #4 of 21 Old 02-09-2010, 09:24 PM
Wright Guard
 
phreebsd's Avatar
 
Join Date: Dec 2004
Location: Bama
Posts: 6,758
Images: 37
           
it is a mode that limits the bike to 3500 rpm i think. anyting past 1/3 throttle sounds like the reve limiter is activated.

2008 Kawasaki Teryx
31" Laws
Black ITP SS212's
Relocated Radiator
Maroon Primary
Yellow Secondary
MIMB Snorkels (dual 2" intake)
Rejetted
RaceDriven Sintered Metal Brake Pads
BigGun EVO Exhaust
Viper Max 5000 WideSpool with Amsteel Blue

TEAM ROLLIN' DEEP 2013
phreebsd is offline  
post #5 of 21 Old 02-09-2010, 09:25 PM Thread Starter
Newbie
 
troydorics's Avatar
 
Join Date: Feb 2010
Location: Ellenton, FL
Posts: 13
 
na i have full throttle.. just runs crappy getting there haha
troydorics is offline  
post #6 of 21 Old 02-09-2010, 10:00 PM
Rollin' Deep
 
BigIzzy's Avatar
 
Join Date: May 2009
Location: Treherne Manitoba Canada
Posts: 356
Images: 3
 
I had the same problem after I sunk mine, coughs and sputters, no power and hard time getting too WOT, backfiring etc. I got frustrated with it, after running seafoam through it and checkin plugs etc, so I took it too the stealership. Found mud in the bowls, cleaned em up, and adjusted the valves while it was torn apart. Have ya sunk her at all? or been close and didnt think ya did and maybe she got a gulp? Cause that sounds like the problem, but one of the many other master minds here will probably chime in with some other possibilies. Good Luck and welcome too the site, great bunch of guys and gals here

07 Brute 650i
ITP Mud Lite XTR's
ITP S&S 108 Rims
MIMB Snorkel
2" RDC lift
Relocated Rad
8000k HID's
Audiotube
BigIzzy is offline  
post #7 of 21 Old 02-09-2010, 10:03 PM Thread Starter
Newbie
 
troydorics's Avatar
 
Join Date: Feb 2010
Location: Ellenton, FL
Posts: 13
 
yeah i thinking something has gotten in the bowls or something... only one way to find out right!!!
troydorics is offline  
post #8 of 21 Old 02-09-2010, 10:06 PM
Rollin' Deep
 
BigIzzy's Avatar
 
Join Date: May 2009
Location: Treherne Manitoba Canada
Posts: 356
Images: 3
 
very true man, sounds like it, but someone else here may have something outta the blue that it could be, I cant think of anything else that I have heard of tho

07 Brute 650i
ITP Mud Lite XTR's
ITP S&S 108 Rims
MIMB Snorkel
2" RDC lift
Relocated Rad
8000k HID's
Audiotube
BigIzzy is offline  
post #9 of 21 Old 02-09-2010, 10:16 PM
Professional Mudder
 
drtj's Avatar
 
Join Date: May 2009
Location: Tifton Ga
Posts: 1,026
 
Have u snorkled it or put a pipe on it recently?
drtj is offline  
post #10 of 21 Old 02-09-2010, 10:19 PM Thread Starter
Newbie
 
troydorics's Avatar
 
Join Date: Feb 2010
Location: Ellenton, FL
Posts: 13
 
nope still bone stock... I'm starting to think its an ethanol problem... My brute set for a little bit
troydorics is offline  
post #11 of 21 Old 02-09-2010, 10:29 PM
Professional Mudder
 
drtj's Avatar
 
Join Date: May 2009
Location: Tifton Ga
Posts: 1,026
 
Could be old gas or trash in the carbs or in tank
drtj is offline  
post #12 of 21 Old 02-09-2010, 10:31 PM
Professional Mudder
 
Masher's Avatar
 
Join Date: Jan 2009
Location: Loranger, La
Posts: 1,361
 
Yep, you just need to dust off the bowls.

2008 Red Brute Force 750 FI
2" Xtreme Lift
31" Outlaws 9.5 Front 11 Rear
EPI Red Secondary
14" SS112s
Full Muzzy
PCIII
1.5" Wheel Spacers

Shaft Deep ATV Club!
Diarrhea Slingers ATV Club!
Masher is offline  
post #13 of 21 Old 02-09-2010, 10:43 PM Thread Starter
Newbie
 
troydorics's Avatar
 
Join Date: Feb 2010
Location: Ellenton, FL
Posts: 13
 
thanks for all your help guys!!! any good tips to getting the carbs off... i have had the plastics off to look at them... looks like a pain
troydorics is offline  
post #14 of 21 Old 02-10-2010, 02:02 AM
Honored Member
 
FABMAN's Avatar
 
Join Date: Dec 2008
Location: St Francis MN
Posts: 780
Images: 92
 
Use a drill or screw-gun with a phillips bit is best. It'll knock 15-20m off. Oh and don't push to hard on the screw's holding the little black pocket side things on.

THERE IS NO REPLACEMENT FOR DISPLACEMENT

07 BRUTE FORCE 840i FST

3" MANDRAL BENT SNORKEL, BIG GUN FULL EXH, JETED 170 F 175 R, Dyna fully programmable cdi, Dyna coils, VFJ stage 3 spider mod Clutch, racked radiator, CUSTOM FULL SKID"S by me, CUSTOM REAR BUMPER by me, CUSTOM reinforced stock rims by me,


mrs. Fabman. 05 Brute Force 750 3000lbs winch 4' plow
JETED

Fabjr. Polaris Scrambler 400

Little Miss broke it. Apex 90 cc pro shark
FABMAN is offline  
post #15 of 21 Old 02-10-2010, 03:25 AM
Experienced Mudder
 
Crawfishie!!'s Avatar
 
Join Date: Dec 2009
Location: Flint, Tx
Posts: 767
Images: 1
 
Send a message via Yahoo to Crawfishie!!
Welcome to THE BEST forum on the web!!!! I have been here for a little over 2 months now, let me tell ya......the knowledge you will walk away with, the endless resources, and genuine people that are more than willing to help out......

2008 RzR
29.5" Terminators
ITP aluminum wheels
Dual LTE
snorkles
1/2 windshield
front bumper
HID headlights
SuperATV 6" Lift
EPI clutch kit
Crawfishie!! is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
June - Site Feature Highlight - SMS Text Messaging! phreebsd Site News 20 08-24-2010 03:35 PM
Great info site! madppcs General Tech. & Audio Info. 2 10-06-2009 12:56 PM
August - Site Feature Highlight - SEARCH Function! phreebsd Site News 2 08-07-2009 09:13 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome