Brute Force 650i shuts down after 5 sec. - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-01-2018, 06:04 AM Thread Starter
Newbie
 
Join Date: Jul 2011
Location: Michigan
Posts: 4
 
Brute Force 650i shuts down after 5 sec.

My 2007 BF 650i recently had been bogging down severely with no power under any load or increase in fuel demand, including any medium revving in neutral.
It was running normally other than that. So I took fuel tank out and cleaned it (there was a fair amount of debris), inspected the fuel pickup and fuel pump (both seem fine) and put it back together.
Now it starts just fine, but runs for 5 seconds and shuts down as if I turned the key off. Will crank but no fire. If I turn the key off then back on, it starts fine up and I can rev it right up with no sputtering (unlike before), but it still shuts down again in 5 seconds. Crank no fire. This is repeatable indefinitely, whether I let it idle or throttle it up to 2000 or so. In fact, if it dies while in a high idle, I can turn the key momentarily OFF then back ON while it's still spinning and it will regain ignition and keep running (for another 5 seconds)
Seems like an ignition problem rather than fuel. Your thoughts on this would be greatly appreciated ツ ツ
marklpenni is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 08-01-2018, 06:51 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,285
Images: 77
         
That's a new one on me, but I agree it sounds like a short somewhere in your ignition.


MIMB - The REAL "Brute Central"
  • Sold: '00 Polaris Xpedition 425
  • Sold: '86 Honda 350X Trike
  • Sold: '00 Polaris Scrambler 500 4x4
  • Sold: '07 Brute 750
  • Sold: 2011 Camo LE TeRyx
  • New: 2019 Sportsman 570 EPS


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
post #3 of 6 Old 08-01-2018, 01:21 PM Thread Starter
Newbie
 
Join Date: Jul 2011
Location: Michigan
Posts: 4
 
I suppose there are any number of inputs to the ignition module that could tell it to shut down. Is there a downloadable service manual with wiring diagram out there? Thanks!
marklpenni is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 08-01-2018, 03:17 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,258
           
Roll-over sensor is upside down I'll bet.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #5 of 6 Old 08-02-2018, 09:31 PM Thread Starter
Newbie
 
Join Date: Jul 2011
Location: Michigan
Posts: 4
 
Well NMKawierider, you hit the nail pretty much on the head! I had a loose connection at the rollover sensor. All is well now. Sincere thanks from MI to NM! ツ ツ
marklpenni is offline  
post #6 of 6 Old 08-03-2018, 06:30 AM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,258
           
Cool.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
09 Brute Force 750 running rough fastlane02ss Kawasaki 3 07-27-2017 10:41 AM
650i owner thinking of moving up to 750 -- looking for opinions/advice Roody Mud Pit 3 10-02-2016 08:13 AM
08 brute force 750 help needed! Kawi gang Kawasaki 14 02-27-2016 07:29 AM
brute force eating belts help ryanharrington827 General Tech. & Audio Info. 6 02-11-2016 05:25 AM
2012 Brute Force 650i bruteforce_ttu For Sale/Trade 0 01-27-2016 06:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome