2013 bforce 750i SE EPS - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 12-26-2018, 06:51 PM Thread Starter
Newbie
 
Bforce750i's Avatar
 
Join Date: Dec 2018
Posts: 6
 
Garage
2013 bforce 750i SE EPS

Hello, need help for problem im having,thinking it may be fuel filter or injectors from the posts that iv been reading, weird tho either way hope somone can help.

7200km 500hrs, 2013 , No major mods, plugs are good and clean , airbox clean, gas always clean going in.

The brute ran fine all day for a hour and then later on stopped for a few minutes to idle.
Started to go again and the bike would bog past 1/2 throttle, then get worse then get better and eventually was able to go 3/4 throttle no problem. Eventually could full throttle again without back fire.

It comes and goes somedays riding , please help anyway

Bb
Bforce750i is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 12-26-2018, 07:34 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,294
           
Quote:
Originally Posted by Bforce750i View Post
Hello, need help for problem im having,thinking it may be fuel filter or injectors from the posts that iv been reading, weird tho either way hope somone can help.

7200km 500hrs, 2013 , No major mods, plugs are good and clean , airbox clean, gas always clean going in.

The brute ran fine all day for a hour and then later on stopped for a few minutes to idle.
Started to go again and the bike would bog past 1/2 throttle, then get worse then get better and eventually was able to go 3/4 throttle no problem. Eventually could full throttle again without back fire.

It comes and goes somedays riding , please help anyway
Sounds like the vent check is stuck. Next time it happens loosen the gas cap. If it clears-up, replace it. If not, check fuel pressure and volume. Might have a bad pump or there may be water in the tank.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
Reply

Bookmarks

Tags
back fire , bog , brute , filter

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 brute questions BruteNasty750 Kawasaki 3 05-15-2017 12:56 PM
2013 650 Brute Force SRA megabitez Tire/Rim 411 4 03-23-2017 02:56 PM
King Quad 750i Engine dies when turn in low speed Tasos Suzuki 1 02-06-2017 03:32 PM
2013 Brute 750 Front diff and steering question JS29 Kawasaki 8 06-21-2016 09:26 AM
2013 F150 Polaris425 For Sale/Trade 0 02-11-2016 11:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome