Belt or engine braking noise? - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-08-2019, 05:48 AM Thread Starter
Newbie
 
Join Date: Feb 2019
Posts: 1
 
Belt or engine braking noise?

Hey guys, I have a ‘14 Brute that is making some noise. When going downhill under engine braking, it will kind of let loose and make a God awful noise. Not a clanking, but somewhere between a screech and grinding sound. If I give a little throttle, engine braking will re engage and the sound goes away. It will do it again and again all the way down though. I don’t have any trouble when going uphill, or anytime I’m on the throttle. I thought maybe the belt was slipping, but it looks like it’s in good condition, and the deflection seems in spec. The engine braking fork and the bearing on the drive clutch have some caked on/dusty residue on them. It only has 125 hrs and about 600 miles in the whole quad. Any of you smart guys know what the problem is?
Paul. is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-11-2019, 08:36 AM
Forum Admin.
 
Polaris425's Avatar
 
Join Date: Dec 2004
Location: Tuscaloosa, Al
Posts: 15,285
Images: 77
         
I think that's how it's supposed to work isnt it? You have to blip the throttle a little to engage it?

It's been so long since I sold my brute I can't really remember.


MIMB - The REAL "Brute Central"
  • Sold: '00 Polaris Xpedition 425
  • Sold: '86 Honda 350X Trike
  • Sold: '00 Polaris Scrambler 500 4x4
  • Sold: '07 Brute 750
  • Sold: 2011 Camo LE TeRyx
  • New: 2019 Sportsman 570 EPS


www.MudInMyBlood.com We Have a Thread for That...
Polaris425 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 brute force belt switch question mtbrice Kawasaki 3 04-17-2018 07:42 AM
King Quad 750i Engine dies when turn in low speed Tasos Suzuki 1 02-06-2017 02:32 PM
New to fourm 2015 brute force 750 noise from clutch area obphil General Tech. & Audio Info. 8 12-16-2016 01:45 PM
Kawasaki 700 prairie belt light Micah Haarhoff Kawasaki 4 11-28-2016 01:04 PM
450 foreman clutch noise? Tunz Honda 0 02-23-2016 12:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome