2008 brute force sputters but if you flip kill switch off and on itís fine - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 06-28-2019, 01:08 PM Thread Starter
Newbie
 
Join Date: Jun 2019
Posts: 3
 
2008 brute force sputters but if you flip kill switch off and on itís fine

I have a 2008 brute force 750i runs great for about a hour then starts to sputter and not wanting to take the throttle but I can flip the kill switch off and on and it’s runs great again for about 15 min. Does anybody know or have had this problem before
Deerhead334 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 06-28-2019, 02:25 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,285
           
Quote:
Originally Posted by Deerhead334 View Post
I have a 2008 brute force 750i runs great for about a hour then starts to sputter and not wanting to take the throttle but I can flip the kill switch off and on and itís runs great again for about 15 min. Does anybody know or have had this problem before
I'm going to say either a charging issue making the coil voltage low or a grounding problem somewhere.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #3 of 8 Old 06-28-2019, 05:01 PM Thread Starter
Newbie
 
Join Date: Jun 2019
Posts: 3
 
Alright thanks I’ll try that this afternoon and see at first it was sputter do to the fuel dock being stoped up but I went ahead and put a new fuel pump but then I noticed it was still sputtering a little so I put new spark plugs and 2 new coils and still has the same problem
Deerhead334 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 06-28-2019, 05:37 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,285
           
Have you checked the injectors for operation? If anything got by the pump it will be in them.

06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
post #5 of 8 Old 06-28-2019, 08:12 PM Thread Starter
Newbie
 
Join Date: Jun 2019
Posts: 3
 
I haven’t looked at the injectors yet but I wouldn’t see why they would act up and then be fine when I flip the kill switch
Deerhead334 is offline  
post #6 of 8 Old 07-15-2019, 04:38 PM
Newbie
 
Join Date: Jul 2019
Posts: 16
 
How many times have you got it to run good again by flipping the kill switch off to on?

2010 BF 750
Moosiani is offline  
post #7 of 8 Old 07-15-2019, 04:43 PM
Newbie
 
Join Date: Jul 2019
Posts: 16
 
If it’s happened many times you need to look at it like this. Something is getting to hot and by switching it off and on your restring something. Do you know if your losing spark (weak spark) or fuel pressure ( lack of pressure. One simple cheap start would be switch the fuel pump relay with another relay and try it. I’d start there. Obviously this will be a process of elimination. I’ve seen relay flutter once hot. If it is your losing fuel pressure and volume. Also is the F1 illuminating when the problem occurs?

2010 BF 750
Moosiani is offline  
post #8 of 8 Old 07-15-2019, 04:48 PM
Newbie
 
Join Date: Jul 2019
Posts: 16
 
I would also check all grounds to make they are tight and clean all relevant connectors. Doing this may not fix it but may prevent future issues. And it only costs some time.

2010 BF 750
Moosiani is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome