06 BF 750 what's supposed to go here? - MudInMyBlood Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Today, 04:27 PM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 1
 
06 BF 750 what's supposed to go here?

I just got a 06 brute 750 given to me by a friend. I was told that it had a top end rebuild, for what? Not sure. There were no spark plugs when i got it. I went out bought new battery, spark plugs and a spark tester. When picking it up (guy doesn't know much about ATV's neither do i) said that it may be starter relay or something and pointed to a harness that has two prongs coming out which look like small fuses go into and stated he thinks that was the problem. I cannot find anywhere what they belong to.
Installed new battery and tested spark all I get is the starter spinning, no engine turning over. Tested spark with a tester and got nothing. Not sure where to start or what goes into that harness is the culprit.
Attached Thumbnails
Click image for larger version

Name:	Bf7502-2.jpg
Views:	4
Size:	1,015.9 KB
ID:	19952  
Jaywilll013 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Today, 07:10 PM
Moderator
 
NMKawierider's Avatar
 
Join Date: Apr 2009
Location: NM
Posts: 7,286
           
Quote:
Originally Posted by Jaywilll013 View Post
I just got a 06 brute 750 given to me by a friend. I was told that it had a top end rebuild, for what? Not sure. There were no spark plugs when i got it. I went out bought new battery, spark plugs and a spark tester. When picking it up (guy doesn't know much about ATV's neither do i) said that it may be starter relay or something and pointed to a harness that has two prongs coming out which look like small fuses go into and stated he thinks that was the problem. I cannot find anywhere what they belong to.
Installed new battery and tested spark all I get is the starter spinning, no engine turning over. Tested spark with a tester and got nothing. Not sure where to start or what goes into that harness is the culprit.
Those look like where the fan breaker goes...Your fan won't work without it. Now...sense the starter spins but the engine does not, that means there is something wrong with the starter drive gears, one way spragg or the flywheel is loose. I got a bad feeling on this one..sorry man I think he f-ed you, but get the service manual and start pulling the side cover off and see. I might pull the belt cover first and see if the primary clutch can even turn. Its straight on the end of the crank and if it won't turn...you have a parts bike...or you are about to fork-out for a full rebuild. Look to nFlow for help there. They are good people and will treat you right.


This is a pic of mine and what that fan breaker looks like. Many just put a 10 amp fuse and holder in it's place when they go bad.





06 BF 750 (Silver) SOLD
15 Z Force 800 EPS


My Videos on You Tube
NMKawierider is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome