MudInMyBlood Forums - Reply to Topic
Thread: Renegade wet belt Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :

Register Now



In order to be able to post messages on the MudInMyBlood Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-01-2015 02:16 AM
youngDUMP Check your clamps for your intake/exhaust ports on the belt box. Make sure the couplings aren't torn. Pop the belt cover off and inspect your gasket, I always put a thin layer of triple guard marine grease on mine when reassembling. The only other way I know to find a belt leak is to fill the system with water and look for where it's leaking out. Note the leak, drain the system and address the leak. (I do NOT recommend this for air intake) Hope this helps. Good luck.


Sent from my iPad using Tapatalk
09-25-2015 08:25 AM
renegade500
Quote:
Originally Posted by hursteric View Post
I would check the gasket around your belt box and be sure that all your fittings for the snorkel are glued properly. Also how high up is the intake and exhaust for the belt box? If its up by the handle bars and the water you went through was only a few inches then i would think your belt box gasket is the issue.
The snorkels are right in front of my handle bars under that plastic. the exhaust is high and they weren't close to being under water. The seal must be bad. Bought it brand new a few weeks ago so not too happy.
09-25-2015 08:01 AM
hursteric I would check the gasket around your belt box and be sure that all your fittings for the snorkel are glued properly. Also how high up is the intake and exhaust for the belt box? If its up by the handle bars and the water you went through was only a few inches then i would think your belt box gasket is the issue.
09-25-2015 07:05 AM
renegade500 Has anyone else had problems with renegades getting wet belts and then slipping when wet while they are being completely bone stock? My renegade is bone stock and has a stealth snorkel system. Went through some water but nothing crazy just a few inches and my belt got wet and started slipping. How could I fix this?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome