Mud in My Blood Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Curious question to all brute force 750 riders, I recently picked one up ran fine, but for a 750cc vtwin it seemed low on power/torque so I decided to do all new cylinders and pistons, got her together and it made little to zero difference, I see videos of other owners, giving theirs very little throttle and the front end jumps up, I don’t think I could even force mine to do a wheelie. ANY ADVICE OR INSITE!?
 

·
Super Moderator
Joined
·
7,603 Posts
What tests did you do? What's the compression? How are the valves and valve timing..lash settings? Did you do a leak-down test to see where any leakage was? How about fuel pressure and volume tests? Any Brute running correctly will try to pull it's bars out of your hands. If not..something is wrong. Just a matter of finding it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Mine is the carb model, compression seems good, it runs well has full range of rpm, just seems like it has a stall it’s doesn’t engage the clutch quickly, I have no idea at this point I expected much more from this dang thing, do you know the valve specs?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
What tests did you do? What's the compression? How are the valves and valve timing..lash settings? Did you do a leak-down test to see where any leakage was? How about fuel pressure and volume tests? Any Brute running correctly will try to pull it's bars out of your hands. If not..something is wrong. Just a matter of finding it.
I hear people saying that once valves are adjusted properly that it’ll make it 100% better, although I don’t think they need adjustment, it’s like it’s running on one cylinder, but I’ve checked most definitely running on both, same compression same everything.
 
1 - 6 of 6 Posts
Top