Mud in My Blood Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys new to the forum and I’m having an issue with power loss so I wanted to see if y’all had any advice. I tried searching but didn’t have much luck. I bought an 05 BF 650 from my dad (he bought it brand new) about 3 weeks ago. The first couple weeks everything ran great with zero issues. I did a service on the bike changing the oil, rear diff/wet brake fluid, and flushing and adding new coolant. Bike still ran great. About a week ago I put new Maxxis Big Horn 2.0 tires on and took it out on my street to test them out. I noticed that at full throttle (in Low and High) the bike would only reach 20-25mph. I’ve done some troubleshooting myself but haven’t seemed to find the issue yet. I’ve replaced the spark plugs, taken off the fuel tank and checked the filter on the fuel pump, checked the fuel pump itself, ran sea foam through it, checked the belt (defection switch inside the belt housing was in the ON position). I’m running out of things that I know of to check. Any help would be greatly appreciated. Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Eryxian, I’m honestly not sure. I’ll have to go get a compression gauge and see. What’s the magic number I should look for?
 

·
Premium Member
Joined
·
24 Posts
Hopefully something over 100psi; the lower the psi, the greater the need for rings and maybe pistons to be replaced.

You hadn't mentioned them being done, after 15 years, there is a good chance you might need a new set of rings at least.

Sent from my SM-N950W using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Ok thanks I will check that out ASAP. Also, any chance that it could carb related? It ran perfect until it got “low” on fuel. I refilled the tank and ever since then it’s been having issues. Before I bought it it had sat for a few months only being driven a couple days in that span.
 

·
Premium Member
Joined
·
24 Posts
Sure, clogged fuel pump or fuel filter can restrict flow as well, especially at WOT.

I have compression gauges, so it's an easy check on old engines.

If it is a powerloss at WOT, that means it would be your main jet is clogged if it's the carb.

Sent from my SM-N950W using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Ok thanks, I’m going to mess with it tomorrow evening. It seems to run better (feels and sounds a lot smoother) while fully choked. Does that point more towards the carb than a compression issue?
 

·
Premium Member
Joined
·
24 Posts
Not specifically, you are altering the air-fuel mixture and while the choke is on you are bypassing part of the main jet.

Sent from my SM-N950W using Tapatalk
 
1 - 8 of 8 Posts
Top