Mud in My Blood Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Im barely getting any power to the wheels and i dont want to pull the clutch apart until im sure that is what the problem is. I can give the bike 1/4 to almost 1/2 throttle and just revs up and still at half throttle its only creeping. Any suggestions?
 

·
Moderator
Joined
·
7,386 Posts
Im barely getting any power to the wheels and i dont want to pull the clutch apart until im sure that is what the problem is. I can give the bike 1/4 to almost 1/2 throttle and just revs up and still at half throttle its only creeping. Any suggestions?
Well I would say the belt or clutch is gone. Time to pull it down and see.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
I have already pulled the cover while its running and tried to give it gas and the belt isnt slipping. Its probably the primary spring is worn out?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
And if it is the primary spring would i better off buying a clutch kit or just the primary?
 

·
Registered
Joined
·
215 Posts
Wet clutch is wore out and needs to be replaced. I wouldn't drive it cause it will wear the drum out too.
 

·
Registered
Joined
·
215 Posts
It's neither, the wet clutch is in the motor. The shaft that the primary is on is what I'm talking about the wet clutch on the opposite end of that shaft inside the motor. I will try to get u some pics when I get to a computer
 

·
Registered
Joined
·
215 Posts
I know this is a suzuki kingquad but its basically the same as your grizzly watch it and you will understand were the wet clutch is located.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #11
Im sorry to keep bothering everybody but now it wont start. We have already pulled the spark plug and its getting fire. You can try to start it and it will turn over but its like its not getting fuel and now we pulled the tank off and try to start it and it would bog down and the starter will just stop trying. So then we thought it was the battery so we got it checked and its good. We are just stuck, can anyone help please?
 

·
Registered
Joined
·
215 Posts
It's its got a spark and getting fuel check the valves could be to tight
 

·
Registered
Joined
·
30 Posts
Discussion Starter #13
Im not sure, we just pulled the starter and seen if maybe the starter was getting worn out but it spins just fine when its not bolted onto the motor. Its not the starter either though because be just tried to turn the motor over using pull rope assemply with a screwdriver and it takes a hell of alot of muscle to turn the motor over and the spark pulg is out so there shouldnt be any compression.
 

·
Registered
Joined
·
1,098 Posts
nick im thinking its someting internal. if its hard for the bike to urn over with the spark plug out it has to be someting internal
 

·
Registered
Joined
·
1,098 Posts
also did yall put an extra power sorce to the bike when it started to struggle like i told u? if not do that cuz ur battery may be getting weak!
 

·
Registered
Joined
·
30 Posts
Discussion Starter #19
Nah we brought it to autozone yesterday and had it checked and they said its fine and we let it trickle charge all night. And its still doing the same thing. Thats what tim is thinking too but the sounds that we are hearing are coming from the clutch side of the engine and we are thinking its ine of the bearings on tht side of the engine that is worn out and wont let the shaft spin. Sometimes the shaft will spin fast like its supposed to and then others it just turns really slow and the starter struggles then the battery dies. If someone could just listen to it im sure they could give a diagnosis.
 

·
Registered
Joined
·
1,098 Posts
record it and send it to me. also hook up a back up power to the bike may help it more. battery sounds weak and with extra power it will help it out more.
 
1 - 20 of 32 Posts
Top