Mud in My Blood Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, new to the forum, great place.

My issue, 04 Eiger that when I push the starter button nothing happens. Pull the cord starts right up. So I assume I have an electrical issue somewhere. I suspect its in the rear brake switch located behind the foot brake. Reason being, with lights off, when I hit the brakes ( either hand or foot) brake light does not come on. When I turn the lights on, rear light comes on but no change when brakes are applied.

Anyone seen this before or suspect it may be something else? Any way to bypass this switch ?

Thanks
 

·
Administrator
Joined
·
15,356 Posts
Maybe the battery is just too weak to start it?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
battery is good, had it on the charger, tested etc. runs the winch no problem. Starter relay doesn't engage when starter button pressed.
 

·
Registered
Joined
·
2,042 Posts
get a meter and test to see if you are getting power to the relay.. if so, then the relay is bad, if not, then it could be the button itself, or the brake switch, but it should start without the brake in Neutral...
 

·
Registered
Joined
·
72 Posts
I had a problem with my starter 06 eiger and it turned out to be the wire to the fuse took the fuse out and cleaned the wires.

it sounds like the brake light side of the bulb is blown
 

·
Registered
Joined
·
72 Posts
Hi, new to the forum, great place.

My issue, 04 Eiger that when I push the starter button nothing happens. Pull the cord starts right up. So I assume I have an electrical issue somewhere. I suspect its in the rear brake switch located behind the foot brake. Reason being, with lights off, when I hit the brakes ( either hand or foot) brake light does not come on. When I turn the lights on, rear light comes on but no change when brakes are applied.

Anyone seen this before or suspect it may be something else? Any way to bypass this switch ?

Thanks
I just unpluged it and took it off. Everything still works just fine but no foot brake light.


And welcome to MIMB
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Thanks for the replies, have been out of town but will be doing some trouble shooting soon.
 
1 - 7 of 7 Posts
Top