Mud in My Blood Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I bought my 2012 brute force 750 with a wild boar radiator relocate kit already installed. The problem is that the reservoir is not hooked up correctly. The hose at the bottom of the reservoir is just ran up underneath the plastics.:thinking: The hose coming from the top of the reservoir is hooked up, but I want to double check everything before I go ride. I was wondering if anybody has the instructions for this kit or could show me a diagram to make sure that I hook it up correctly. I tried to get a hold of wild boar but haven't gotten anything by email or phone. Thanks in advance.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Its the one that is coming from the bottom of the reservoir. Isn't that an actual fill line? I would think that should be hooked up to the radiator so that it could flow into it when it needs to.
 

·
Registered
Joined
·
324 Posts
which one of these lines specificly?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Pictures are very helpful, thanks. On mine both of the clear lines are hooked up to the radiator like yours. Where do those clear lines run? They should connect into the coolant reservoir, right? The two lines that attach to my coolant reservoir are black.
 

·
Registered
Joined
·
324 Posts
the clear line comming from the top radiator cap runs to the coolant tank. the clear line from the fan runs up to the pod.

---------- Post added at 12:35 PM ---------- Previous post was at 12:33 PM ----------

since someone else installed that rad kit, make sure none of your cooling lines are on or near the front exaust header. otherwise, they tend to melt.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
By pod you mean the instrument cluster? I will definitely check when I get home. So are you saying that there is only one line that runs to the reservoir. I don't have my atv in front of me to look.
 

·
Registered
Joined
·
324 Posts
yes.one line to the bottom front of the resivoir. there is one line that runs from the resivior(by cap) , towrds the back of the bike somewhere also. i think it is the overflow line and i dont know really where it ends up. . and yes, the POD is the didgital instrument display in the center of the handle bars. Alot of riders run their vent lines up to it, because it is the high point on the bike.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Okay thanks man I appreciate your help. I will let you know how it works out after this weekend
 

·
Registered
Joined
·
324 Posts
ok , no problem. have a great ride.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11 (Edited)
Okay here are labeled pictures of how my radiator is hooked up currently. I haven't found any instructions for the Wild Boar Relocate kit. I am not sure if this is correct. I have two lines that are going up to the pod for vent lines. It seems to me like they would need to be hooked up to form a suction to suck antifreeze out of the reservoir. Please let me know if this is hooked up correctly.
 
1 - 11 of 11 Posts
Top