Mud in My Blood Forum banner
1 - 20 of 35 Posts

· Registered
Joined
·
305 Posts
I hope for your case its not the same thing that happened to mine when it sounded like that.

The guys here are great and should be able to help you trouble shoot your noise it could be the clutch itself or the bottom end like mine was, just hope for the clutch to be the culpret its a MUCH cheaper fix
 

· Premium Member
Joined
·
2,420 Posts
What year is your brute chine?
How long have you owned it?
Did the noise just start or have you been hearing it for awhile?
Does it do it in gear or neutral....or both?
Have you slipped the belt recently?
Has it every been sunk in water?

The clutches are noisy on these Vtwins even when there new but you may have something else going on. Give us a little more info on what you got and what its doing.
 

· Registered
Joined
·
573 Posts
I've heard this noise twice on mine before, it was crank bearings both times. The second time i got smart and drained my oil and removed the filter to check for those little brass filings in the oil (the ones that come from the bearings when there all ground up). This is something i would definitely check first, its cheap and it'll tell you the one thing that you really don't want to know. Hope its something different for your sake.
 

· Registered
Joined
·
573 Posts
I hope for your case its not the same thing that happened to mine when it sounded like that.

The guys here are great and should be able to help you trouble shoot your noise it could be the clutch itself or the bottom end like mine was, just hope for the clutch to be the culpret its a MUCH cheaper fix
hey jmeier1981 did you end up getting your machine fixed at the dealer? if so how much?
 

· Premium Member
Joined
·
1,880 Posts
What year is your brute chine?
How long have you owned it?
Did the noise just start or have you been hearing it for awhile?
Does it do it in gear or neutral....or both?
Have you slipped the belt recently?
Has it every been sunk in water?

The clutches are noisy on these Vtwins even when there new but you may have something else going on. Give us a little more info on what you got and what its doing.
.......:thinking:.....Where did he go???? ....We just wanna help:haha:
 

· Premium Member
Joined
·
10,380 Posts
I think mine is starting to knock too! Crap
 

· Premium Member
Joined
·
10,380 Posts
haha it started that crap on the last day of the ride. i had let the oil get low from wheels in the air. when i drained the oil it was sludge. not water but oil sludge. :(
i flushed it out with diesel and then flushed oil thru 2 more times.
final fill was 20-50 mobile 1 vtwin with some lucas additive. it's barely quiter.
 

· Premium Member
Joined
·
1,880 Posts
If I were you I would go ahead and get bearings for it ,as the slop gets worse brass shavings will begin to wear everything else in the motor
 

· Premium Member
Joined
·
10,380 Posts
yep. i thought of that. stop running it now.
but then i said screw it.
i'll end up with new pistons, cam, oil pump to be on safe side, chains, crank, bearings seals and gaskets.
 

· Premium Member
Joined
·
2,420 Posts
Yeah 2shoes is starting to make a noise as well. He let his run low of oil too. I checked the oil for him before the MIMB ride and it did not even touch the stick :eek:

Not sure how long he run it like this. Its not making a lot of noise but when you compare it side by side with mine you can hear it. Also has a slight hint of smoke every now and then.
 

· Registered
Joined
·
573 Posts
what about if its fuel injected?
 

· Premium Member
Joined
·
2,420 Posts
My bike has no fuel shut of.....or at least i ain't seen one :thinking:
 
1 - 20 of 35 Posts
Top