Mud in My Blood Forum banner

1 - 16 of 16 Posts

·
Premium Member
Joined
·
9 Posts
Discussion Starter #1
Buddy of mine has an 06 700 EFI limited edition.... blah blah blah... with 28" tires...

he has went through 4 rear half shafts and now he snapped the shaft that goes from the gear box to the rear end...

The only thing its reliable at is breaking down.
 

·
Premium Member
Joined
·
306 Posts
I have a few AC's and I thik they are very reliable. Any machine will start to break once you start adding mods. I have just about everything possible done to mine and yeah they break. That's part of building them up, it's expectted. Arctic Cats to me fall under this phrase...Reliability thru simplicity. Looka t eh guys racing wspa and baja, those are pretty close to stock bikes. AC is the only one not breaking frames and such. Those guys pound the snot out of them too.

-Marty
 

·
Registered
Joined
·
40 Posts
Two of the guys that ride with us have AC's and the only problems they have is overheating and the speed O cluster not working. Overheating was taken care of by relocating radiator but the other I'm not sure.
 

·
Wilson Creek Riders
Joined
·
152 Posts
I know I have seen some Artic Cats abused, both new ones AND used ones...
The things I mostly saw were axles, and shafts.. This is with tires 29.5 and above... With that much meat, like MTImodquad said, it is expected, atleast it would be for me....
I have seen some OLD ones still running around, that honestly, I dont know HOW they were still running much less still together...
Werent the older ones, the motors more to the rear or something like that??

I tell ya what, if they come out with a 1000cc TWIN Mud Pro, I would seriously have to look at it....
 

·
Premium Member
Joined
·
306 Posts
Well I think you will be looking come this fall there TorkMonster. I know I will be. 2010 it's said to happen....:bigok:
 

·
Breaker of things
Joined
·
1,456 Posts
Two of the guys that ride with us have AC's and the only problems they have is overheating and the speed O cluster not working. Overheating was taken care of by relocating radiator but the other I'm not sure.
Friend of my fathers had a cluster problem and found ouf after replacing several under warranty, then warranty ran out, you can just reset them (guess if you start it before you power up the cluster if f's up).

Packed the connector with di-electric grease, reset it (battery disconnect) and has not had a problem since.
 

·
Registered
Joined
·
48 Posts
I owed an ole 400m, thing was a tank. Have some pics of her on here, my wife was mad when i sold it. I got her a grizz and she said i quote,"Its rides really good but i could run over more stuff with the putty tat"lol
 

·
Registered
Joined
·
1,435 Posts
I owed an ole 400m, thing was a tank. Have some pics of her on here, my wife was mad when i sold it. I got her a grizz and she said i quote,"Its rides really good but i could run over more stuff with the putty tat"lol
you've got some pretty cool pics in your albums. you should make one into an avatar
 

·
Registered
Joined
·
3,312 Posts
I like them....I think they are a tough bike.
 

·
Registered
Joined
·
10 Posts
i ride with 2 cats and both had problems with bevel gears
 

·
Registered
Joined
·
10 Posts
but they have both been weeeeell riden
 

·
KAJUN MUD SLINGERS
Joined
·
88 Posts
i totalled an artic cat 500 at 15 miles per hour flipping breaking my ankle in the process so they aint really built to strong and i dont find the engines last
 

·
Registered
Joined
·
38 Posts
I just bought the 700cc Mud Pro a few weeks ago and it overheated 2 hours into its maiden voyage with my wife and 2 year old! My wife took it back to the dealership and they "replaced a relay" and had it back on the trailer in 15 minutes...other than that, so far so good. I just wish they came with more aggressive tires than the MST's
 

·
Premium Member
Joined
·
306 Posts
I just bought the 700cc Mud Pro a few weeks ago and it overheated 2 hours into its maiden voyage with my wife and 2 year old! My wife took it back to the dealership and they "replaced a relay" and had it back on the trailer in 15 minutes...other than that, so far so good. I just wish they came with more aggressive tires than the MST's
Congrats on the new bike!! Do you do a lot of mud riding?? If so , putting the radiator up on the front rack really helps them stay cool.
 

·
Registered
Joined
·
38 Posts
thanks for the tip. any suggestions on where to find a relocate for her? I ride mostly in the mud and around my farm. its been rack deep a couple times without any problems yet, but I dont wanna press my luck!
 

·
Premium Member
Joined
·
306 Posts
thanks for the tip. any suggestions on where to find a relocate for her? I ride mostly in the mud and around my farm. its been rack deep a couple times without any problems yet, but I dont wanna press my luck!
You just so happen to be talking to the right guy lol. Check them out on our site. http://www.mudtechinc.com/13.html

There are a few pics of MudPros with our kit on them here...
http://www.mudtechinc.com/10.html

Holler at me if yo have any questions.

-Marty
 
1 - 16 of 16 Posts
Top