Mud in My Blood Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
I just washed my bike and started it up and its backfiring at low rpms but when it gets to higher rpms it stops i dont have dielectric grease in the plugs so could water have gotten in the plugs and thats why its running bad and the plugs are a little old to:thinking::thinking::thinking:
 

·
Premium Member
Joined
·
6,767 Posts
could very well be. You will know if it quits once the bike it totally dry tomorrow.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #3
on your secondary does it feel like its in low gear when you ride cause i jus ordered a lime green just wondering
 

·
Premium Member
Joined
·
6,767 Posts
im in low gear all the time. i got yellow!!

it does lower your gearing a lot. higher RPM's at slower speed. that's why you will be able to turn bigger meats in the thick stuff.

you'll be ok on trails in high. You can still have fun.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #5
thanks im kinda a speed junkie when it comes to wide open trails but a like to deep water ride a lot to so i kinda need the best of both worlds
 

·
Registered
Joined
·
226 Posts
Discussion Starter #6
bikes still backfiring i think i have water in the motor or fouled plugs what u think
 

·
Administrator
Joined
·
15,426 Posts
only backfires at idle?
 

·
Registered
Joined
·
226 Posts
Discussion Starter #8
no just at low throttle its backfiring alot i think theres water in the motor or fouled plugs or both really dont know
 

·
Administrator
Joined
·
15,426 Posts
you dont think you could have accidentally sprayed some down the airbox intake do you? I always cap mine when i wash, and I try to not spray up into the muffler if I can help it. Check your oil, if its milky then yeah you got some water in it. Check ur airbox see if any water was in it.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #10
i put a bucket over the snorkels and i start the bike when i get around the muffler and ill check the oil tommorow but could plugs make it backfire like that
 

·
Administrator
Joined
·
15,426 Posts
yeah if they are fouled I think they could. That seems to be about the only other thing. maybe one of them is so fouled it isnt fireing anymore... which is why its backfireing, that raw gas pouring into hot exhaust is igniting & poping.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #12
yeah when i hammer on it it stammers and then it revs right up if you know what i mean
 

·
Registered
Joined
·
226 Posts
Discussion Starter #13
fixed the back firing problem i changed the plugs it was still back firing and then i checked the choke and it was hanging and it was already running rich so it would make it pop i changed oil and rode the bike today and i has ran the best it ever has
 

·
Registered
Joined
·
24 Posts
Chase make sure you wash the Brute off. We don't want the choke to stick again. I worked on mine until 1 am last night. I am pulling the motor tonight. I lost compression. Otherwise, I had a great time.
 

·
Premium Member
Joined
·
6,767 Posts
wow whatcha gonna do to it?
<hint>
Gonna document the process with pics ?
</hint>
 

·
Registered
Joined
·
226 Posts
Discussion Starter #17
he gulped in a little water and he dosent have compression hes jus going to turn it back to stock clean the crap out of it and take it in for warrenty work 4 year warrenty(lucky:p)
 
1 - 17 of 17 Posts
Top