Mud in My Blood Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
1,527 Posts
Discussion Starter #1 (Edited)
Fried my P650 belt today ! actally had small sections of the outside of the belt come through the snorkel!! Now for my question is that a normal belt failure? I have never had a problem with the belt on the old 400 ( prob not enough motor to burn belt:haha:) this happened about 20-25 hours after i snorkeled my quad . no smoke , no smell, no belt light,no warning, just small sections of the belt comin through the snorkel !!?? Got new one on (kawie belt) and rode about 3 hours But thats another Thread all together... Oh yeah the belt had about 165 hours on it so i knew it was gettin time to get one
 

·
Premium Member
Joined
·
1,798 Posts
I have not had a belt failure yet but I've read many post of people talking about the belt coming apart and come up through there snorkels. As long as your getting good air flow in and out of the belt housing i would not worry to much about it.

Did you check the belt defection when you put the new belt on?
 

·
Premium Member
Joined
·
1,527 Posts
Discussion Starter #3
Amazingly it was right on (belt deflection) couldnt belive that
 

·
Breaker of things
Joined
·
1,456 Posts
When mine broke, it was shreaded too and only 400 miles on it. Clutch was not set up correctly (was a used bike and had a performance clutch installed I did not know about) and then new belt tripping belt light.

After 3 tries by dealer, adjusting belt and clutch, working fine now. Just replaced the belt again (put new springs in and just installed the new spare cause it was of) this week and it's wearing perfect.
 
1 - 4 of 4 Posts
Top