Mud in My Blood Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I have an 09 650 Brute force and it boggs until i have about 3/4 of the throttle pushed down. the dealer said to change the spark plugs and i was wondering if it could be something else. what yall think? please let me know if you have any ideas. would be a big help.:egg:
 

·
Registered
Joined
·
83 Posts
Have you added any mods to it? Or changed anything out that might have cause this?
 

·
Breaker of things
Joined
·
1,456 Posts
Warranty?

If it's an 09, how many miles on her? Can't see you needing plugs or anything else unless you drive alot.
 

·
Premium Member
Joined
·
106 Posts
i checked the manual and the trouble shoot for that prob is to check the plud and see if its tight or check plug gap
 

·
Premium Member
Joined
·
210 Posts
Sounds like something more than a plug to me as well. Let us know. Probably something with the fuel injection. Maybe a partially clogged nozzle.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
ill check the plugs first they look cheaply made on expection and if that doesnt work im contacting the dealer got a 5 yr warranty so hopefully its covered lol ill let yall know thanks!!!! and i have a total of 100-120 miles on it already(2 weeks old)
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
well took it to the dealer and they changed a spark plug messed with the carb and they said it still boggs so i gotta leave it with them for a day or 2:sad2:miss her already
 

·
Breaker of things
Joined
·
1,456 Posts
Don't like it when the dealer says they "messed" with the carb on a brand new bike.
 

·
Premium Member
Joined
·
210 Posts
Guess it couldn't hurt at this point though.
 

·
Breaker of things
Joined
·
1,456 Posts
I just don't understand why the dealer would be telling them to try plugs??

It's freakin' brand new and thier problem, not the owners!!!
 
1 - 11 of 11 Posts
Top