Mud in My Blood Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
I finally got my 2005 brute running after doing a lot of mods and common prob fixes for the brute and snorking it . I have these little screens that go over the snorkel . It will start to back fire and run like **** if I keep it on if I take it off it runs fine meaning there a air blockage so i wanna try to turn the air up since that's causing the prob
 

·
Administrator
Joined
·
15,448 Posts
Take those screens out.
 

·
Administrator
Joined
·
15,448 Posts
If you roll it, you're going to have problems anyway....

Screens or no screens...

So I say instead of having to mess with the carbs, just leave them out. B/C less air, less fuel, = less power....

Do you still have the screen under the air filter? You could try removing it, and putting the snorkel screens in and see if that offsets them some.... Taking that big screen out under the filter should help improve air flow.
 

·
Registered
Joined
·
1,186 Posts
Never had an issue running my snorkels wide open . Even in the rain I had no issues , granted that you have at least a 90 degree turn on the intake snorkel .
 

·
Registered
Joined
·
110 Posts
Discussion Starter #8
Yes I still do have the big screen under my filter . I might just leave it out and leave the screen on my two exhaust and this is what they look like
.
 

·
Registered
Joined
·
99 Posts
I have the EHS snorkel savers on mine, no problem. But I have 3" snorkel for my air intake.
 

·
Administrator
Joined
·
15,448 Posts
Take that filter screen out from under the filter, leave your snorkel ones in, and see if it helps...
 
1 - 10 of 10 Posts
Top