Mud in My Blood Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
2008 brute force 750, was running good then died and wont start. The headlight or taillight won't come on either. The green and red lights come on in the dash and the brake light comes on when applied but no start. Any ideas?

---------- Post added at 06:55 PM ---------- Previous post was at 06:49 PM ----------

it wont even turn over,it's like there is no power.
 

·
Administrator
Joined
·
15,438 Posts
Battery's dead. Cold weather finished it off.

Would be my guess.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
checked the battery its at 12 volts checked the wiring that I could see and the plug ins. Still not power to headlights or starter.
 

·
Registered
Joined
·
104 Posts
I had a bad ground at the starter that did something similar. Everything worked just wouldn't even try to start. Think my headlights may have still worked though. I know the winch and everything else did.
 

·
Registered
Joined
·
44 Posts
How about the fuse..?

There are fuses under the seat. Have you checked them? Sounds like it could be that if there is no power and the Battery is in good shape.
 

·
Premium Member
Joined
·
1,398 Posts
Take the fuse block loose and roll it over so you can see the wires. Wiggle them to make sure none are broken. We had a bad connection on a teryx at the fuse block. We ended up replacing the whole fuse block with individual waterproof fuse holders.
 

·
Registered
Joined
·
1 Posts
I had a bad ground at the starter that did something similar. Everything worked just wouldn't even try to start. Think my headlights may have still worked though. I know the winch and everything else did.
Did the ground look bad cause I have the same problem you had but i cant find out were its bad
 
1 - 11 of 11 Posts
Top