Mud in My Blood Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
what jets do i need to run? i got another 05 brute 750 and put center snorkels on. it has a 3'' rubber 90 off the airbox into a 2'' rubber 90 into 2'' pvc. it has a k&n filter and stock exhaust. i'm pretty close to sea level.
 

·
Registered
Joined
·
3,312 Posts
How is it running??? Give me all the info you can and I will try to help. Every bike is different.....I might live next door....have the same exact set up but tuned different...LOL! How is your plugs looking??? Just post all the info you can about how its running and we can go from there..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3 (Edited)
it was running rich. i put a 136f and 140r in it with the clip on the 4th notch from the spring end and 2 1/2 turns out on the a/f ratio screws. it idles ok but still pops at about 1/4-1/2 throttle. i'm kinda lost here. will i need to move the clip towards or away from the spring?
 

·
Registered
Joined
·
3,312 Posts
Here you go....

1/8-1/4 throttle is your pilot jet

1/4-3/4 is your needle

3/4-WOT is your main jet.

If its poping its lean. You are using a dynojet kit...right??? if so... those jets seem a little lean. I would go up one jet size from and back.....but if it running real good at what you have it at and your plugs look fine just raise your needle up one notch....then see.

Sometimes the Dynotek CDI will give it a tiny pop abougt that throttle range....on some not all Brutes. I will PM you my # if you would just rather call me about...I can help you more that way...easier that typing...LOL!!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
so to raise the needle you need to lower the clip (move clip away from the spring)?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
AUbruterider your old one has held up good. the only thing that has broke was both the back axles but that was my fault. replaced the upper a-arm bushings and a couple of wheel bearings... just normal wear and tear stuff. other than that i haven't had any problems.
 

·
Registered
Joined
·
3,312 Posts
Have you got to work on it any???
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
i've worked on it some. still haven't got it right. i think i'm gone trade it like it is for a grizzly 660 w/ more mods than this one has.i was building this one for my girlfriend but the more i think about it she would probably be able to handle the grizz better anyways. it has about 900 miles vs. this one with 3400.
 
1 - 10 of 10 Posts
Top