Mud in My Blood Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter #1 (Edited)
The saga continues and it's really getting annoying. Anyone have any feedback, advice, tips, anything? Removing it is a LAST resort for me. So I want to try everything else first.

 

·
Premium Member
Joined
·
6,767 Posts
i wish i could see this. Iphone is hating on me for some reason!
 

·
Administrator
Joined
·
15,420 Posts
I dont see a video?????
 

·
Registered
Joined
·
210 Posts
Discussion Starter #4
It was there.... then it went away, now it's back lol
 

·
Administrator
Joined
·
15,420 Posts
k i see now
 

·
Premium Member
Joined
·
6,767 Posts
sorry that was me. I rebuilt the post cache.
im still trying to view the vid.
apparently not ready for iphone yet.
 

·
Team BS
Joined
·
757 Posts
so this noise started after u cleaned the fuse box and got the actuator to working again?

have you tried taking it apart and cleaning it?
 

·
Registered
Joined
·
210 Posts
Discussion Starter #8 (Edited)
Edited... it's back!
 

·
Premium Member
Joined
·
6,767 Posts
Hey man thats great. Turns out the fix was free :)
 

·
Registered
Joined
·
210 Posts
Discussion Starter #10 (Edited)
AHHHH it's back!. I put it back together, drove it around and now it's doing it again.... Guess i'm gonna have to borrow my buddies to see if that's the issue.

What all is involved in removing the engine brake?
 

·
Team BS
Joined
·
757 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter #12
I'm going to try a buddies and go from there. The 650I and 750I have the same engine brake right?
 

·
Premium Member
Joined
·
780 Posts
If I recall Diamond-G makes something that takes it out of the loop so you can leave it unplugged. I just took the fork off mine and left it.
 

·
Registered
Joined
·
210 Posts
Discussion Starter #14 (Edited)
Who is diamond-G?

I've done everything I can with what I have... I'm headed out on a 3 day trip in the morning, when I get home on Friday I'm snagging a buddies KEBC to test it out. If his works then I think I found a replacement on Highlifter want ads around 100bucks. I'd rather it be a dead KEBC than a wiring issue obviously.
 

·
Registered
Joined
·
1,882 Posts
You won't regret doing away with it. The only time I notice mine gone is going down a good size hill and letting the engine return to idle. You will pick up speed but if you give it just a little throttle, the engine starts braking the machine again. Not to mention when you turn the bike off, you don't hear all that whiz bang junk going on in the cvt cover.
 

·
Premium Member
Joined
·
6,767 Posts
I'm going to try a buddies and go from there. The 650I and 750I have the same engine brake right?
yep. even one from a prairie 360 would fit.
 

·
Registered
Joined
·
210 Posts
Discussion Starter #18
Probably... I'm taking it to the dealer saturday. It's got a 5 year warranty and the engine brake is covered. :rockn:
 

·
Registered
Joined
·
210 Posts
Discussion Starter #20
The service manager is my one of my best friends brothers.:rockn:
 
1 - 20 of 25 Posts
Top