Mud in My Blood Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have a P360 with 28" silvebacks that bogs in high range and in low range just not as bad on the smallest of hills and sometimes flat land. I have Pink primary and Red secondary springs. My check belt light is on also . Called my buddy up on the phone he said it sound to him like its the belt from how I explained it to him.. Need some feedback here guys. By the way the carb is clean with a #155 jet.
 

·
Premium Member
Joined
·
1,527 Posts
If the belt light is on it should be in limp mode . I cant belive a P360 will pull 28'' silverbacks :bigeyes: I may have underestimated them
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
Resetting the belt light did the trick for the most part. Still think I need a new belt though. I can here it sqeal through my snorkels. Its like im holding the brake but trying to go. Once my tires are turning no problem. Its just at a stand still it does it?
 

·
Premium Member
Joined
·
1,527 Posts
A light squeal when its in gear at idle ? If so that means deflection is a little tight . but should be fine
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
It does it in gear only and only from a stand still when I hit the gas. Really squeal going up a small hill in my yard
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
It does it in gear only and only from a stand still when I hit the gas. Really squeal going up a small hill in my yard from a stand still
 

·
Premium Member
Joined
·
1,527 Posts
Sounds kinda like the belt is burnt a little . IMO
 

·
Registered
Joined
·
28 Posts
Discussion Starter #11
Just started after I put the silverbacks on it seems like but I never rode it to see with my stock tires due to valves and carb problems. I just had money at the time and just slapped the tires on while I fixed it all and I no longer have the stock tires to test and see .It Did it before the clutching and after the clutching. The belt light was on before I got the silverbacks and I just turned it off it helped a little.
 

·
Premium Member
Joined
·
1,527 Posts
Its prob. catchin he** with those backs LOL ,do you have stock springs in the clutches ?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #15
What is the best belt to get for my 360 ? dayco , epi, highlifter or kawasaki oem replacement? I have read that it is wise to stick to the kawi oem belt.
 

·
Premium Member
Joined
·
1,527 Posts
OEM belt only !!! You prob need a stiffer primary spring
 

·
Registered
Joined
·
74 Posts
Fixing to replace mine on my P360. Why do you say OEM only?
 
1 - 17 of 17 Posts
Top