Mud in My Blood Forum banner

1 - 20 of 31 Posts

·
Team BS
Joined
·
757 Posts
Discussion Starter #1
While in the first hole of the day saturday, my belt area started squealing really bad. i got it back to the truck, took the cover off, and found that the primary clutch started rubbing the heat sheild (or whatever that metal plate is) behind it. it is rubbing in 2 places. does anyone know why or had this happen before?

i just had a belt explode before this ride, and i do torque my clutches to 69 ft-lb. any ideas anyone?
 

·
Registered
Joined
·
13 Posts
Might be a good idea to remove the primary and see if it spun on the crank. Don't really know if this is possible but if the clutch spun it might allow the clutch to get into the shield. The other possibility is that when the belt let go a piece of the belt might have bent the shield into the clutch. Just a couple of ideas as I haven't heard of this before. Hope this helps.
 

·
Team BS
Joined
·
757 Posts
Discussion Starter #3
i actually just pulled the heat shield off and rode it. which is a bad idea, it keeps a oil line from coming loose. but the crank looks fine. and it still rubs when i put it back together. but there doesnt seem to be a wobble to the clutch or the crank. i kinda thought bout the sheild gettin bent from the belt. but i have rode the bike around my house between puttin the new belt on and this happenein
 

·
Premium Member
Joined
·
1,798 Posts
Your not putting any kind of lubricant on the primary shaft are you? Lubricant can cause it to slide in to far and hit the heat shield. The shaft needs to be dry when the primary is installed.

If it's not that then i just don't know.
 

·
Premium Member
Joined
·
6,767 Posts
you can also torque it down too much and it will hit.
69 ft/lbs baby!
 

·
Administrator
Joined
·
15,430 Posts
"and i do torque my clutches to 69 ft-lb."

I think he's got that part ;)
 

·
Registered
Joined
·
1,361 Posts
Torque it to 50 and try it but keep a close eye on it.
 

·
Premium Member
Joined
·
6,767 Posts
i cant read!
 

·
Administrator
Joined
·
15,430 Posts
I wouldn't recommend torqing to anything other than manufacturers specifications..... they are there for a reason.
 

·
Premium Member
Joined
·
1,798 Posts
I wouldn't recommend torqing to anything other than manufacturers specifications..... they are there for a reason.
I agree.


bump530 its a long shot but it may be your torque wench is not calibrated right or simply broken some how. Do you have access to another one to try?
 

·
Team BS
Joined
·
757 Posts
Discussion Starter #11
im gonna check tonite bout the grease/oil on the shaft. i imagine there was some on there. would it tighten up more on its on after it i was ridin or something? cause it wasnt rubbin when i first put it tongether.

i just really hope its the grease/oil. i do have access to another one. mine is not even a year old and barely been used though, but that is a thought. it has been tigthened down wit a impact before we knew anybetter, but i have torqued it the last few times ive taken it off.
 

·
Premium Member
Joined
·
189 Posts
i've got to get me a good toque wrench - i always just hope i dont ever over tighten but i know it happens. I'm going this weekend to get me one. I need to quiet playin the russian roulette on my brute!
Good luck with urs bump - let us know what you find out.
 

·
Team BS
Joined
·
757 Posts
Discussion Starter #13
yeah torque wrenchs are nice. i have never really used one too much till here recently. i try to torque all important items now, instead of using my judgement lol.
 

·
Team BS
Joined
·
757 Posts
Discussion Starter #14
well i cleaned up the shaft and clutch and torqued it on, and its not rubbing any more. makes me feel a lil better, but it did start rubbing while riding, so i hope it doesnt "tighten" itself up anymore. i wont be able to ride it for a lil while to tell, im doin some other things to it at the moment ;)
 

·
Team BS
Joined
·
757 Posts
Discussion Starter #16
i have all the washers. the reason i say "tighten" itself up is becuase it wasnt rubbing until i was in a mudhole. i had rode the bike around the yard and then around a lil bit at the ride before it started rubbing.
 

·
Team BS
Joined
·
757 Posts
Discussion Starter #18
i will. and i wish i could say the "other" things is some motor work, but no. just gettin the PCIII, tuned, catch can, new snorks (something like MIMB), new radiator mount, fan switch, temp guage. there is prolly something im forgettin, but thats bout it.
 

·
Premium Member
Joined
·
210 Posts
It just makes its way up the taper over time if it is overtightened or greasy.
 

·
Team BS
Joined
·
757 Posts
Discussion Starter #20
oh okay, well i hope it stays in ONE spot from now on. i have really finished a ride since i took the lift off, im ready to ride and not worry, well worry as much lmfao
 
1 - 20 of 31 Posts
Top