Mud in My Blood Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I recently purchased a 2013 Renegade 1000 and had a few questions on clutching. I put 30x9/30x11 silverbacks on it and noticed the belt squeal a little when I bump the throttle. I didn't think I would have an issue running those tires because those are the same tires on my 2013 XMR 1000. I was under the impression the XMR used the clutching from the Renegade, yet my XMR does not squeal. Im not sure if its because my XMR is broken in and the Renegade only has 16 minutes on it. Anyway, I really don't want to buy the QSC/STM clutching right now (just bought a bunch of accessories for the renegade, put a $5600 motor in my RZR) and was looking into just the Mudder Clutch Kit from EPI. It comes with weights, a red and white spring. Do you guys think the EPI kit will work with those silverbacks?
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #2 ·
Also, is there any way to run the springs only? I did that on my Brute and it worked well with the 31" s/w outlaws.
 

·
Registered
Joined
·
3,737 Posts
Linkage on here used to run springs only in his renegade and had 32" backs on it so I'm sure you'll be ok. Personally I think I'd go for the Dalton kit over EPI, but thats just preference.
 

·
Registered
Joined
·
336 Posts
Get ahold of vforcejohn he does can am clutching too and it's supposed to be good!


. Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #5 ·
Ok... I installed the Red and White springs and that thing came alive. Now wheelies in H are easy. I think this will work until I decide to go with the QSC STM clutches. Thanks for all the advise.
 
1 - 5 of 5 Posts
Top