Mud in My Blood Forum banner

1 - 11 of 11 Posts

·
Wilson Creek Riders
Joined
·
152 Posts
Discussion Starter #1
Well, I am NOT a big mudder, bud, rode mud, like big mud, ONE TIME.....
THIS is what happened to mine...


Sorry bout the bad pics, was with my phone...
But that lil jewel is the PRE-FILTER on the fuel pump inside the fuel tank..
I rode creek/water all summer long, rode mud ONE time in the winter.. MAN...
That thing is CLOGGED with mud...
I noticed the next time I filled up with gas, that I had a lil mud or remnance of mud inside the filler neck, but didn't think nothing of it.. And didn't NOTICE anything for atleast 7-8 tanks later...
Yesterday on a ride in Crel Springs Illinois, I couldn't get it to run hardly at ALL.... I was thinking fuel pump, along with probus.... Well, that cutting out, and dying was due to that lil thing..
WoW, what a sorry excuse for a fuel CAP... MAN....
 

·
Premium Member
Joined
·
131 Posts
Almost looks like somebody dumped the dirt instead of sugar.. never saw that before..mabey your caps missing a gasket..
 

·
Administrator
Joined
·
15,427 Posts
ouch... there's got to be something missing w/ that cap, as many CAN's as Ive seen in the pits...
 

·
Lets Get It
Joined
·
338 Posts
Man, not good to see!!!
 

·
Wilson Creek Riders
Joined
·
152 Posts
Discussion Starter #6
Well, got her all cleaned up last night, started assembling it this morning. went to crank the key, and ....
Whuuuuuum POWWW!!! lol

She purring like she should again..... Thank GAWD!!!!
Now I just gotta run the tank vents, and I am making some kind of gasket for that cap....
Honestly, i only rode mud, once.. DEEP mud anyways..
I rode the creek all summer long and part of the winter and never had a problem...
Well, least I got it before something terrible happened.. I mean I would HATE to have to rebuild, and put all performance and HC pistons or something in it!!! LOL
Honestly I'm not ready to tear it down YET so I AM glad....
Now, off to go ride somewhere!!
 

·
Lets Get It
Joined
·
338 Posts
Good to hear you got it going agian!!!

I would hate for you to have to put pistons, cams and what not in it, that just wouldnt be no good at all:p;)
 

·
Wilson Creek Riders
Joined
·
152 Posts
Discussion Starter #8
haha, i'd hate them too if I didn't own one.. they sure are hard to keep up with...
 

·
Team BS
Joined
·
757 Posts
u might have a bad gas cap or somehting. but most of the time, that occurs from the mud/water getting in thru the vent in the frame.
 

·
Wilson Creek Riders
Joined
·
152 Posts
Discussion Starter #10
yeah bump I gotta agree..
the vents are now ran up.. lol so hopefully thats what it was...

I guess all summer i was riding with water in the gas too.. all i did was ride creek all summer. and will this summer...
prolly gonna get a new cap just in case...
 

·
Team BS
Joined
·
757 Posts
youll be surprised how much dirt is in creek/river water. but i dont blame ya on the gas cap
 
1 - 11 of 11 Posts
Top