Mud in My Blood Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Have an 08 brute force 750i 4x4 fuel injected. bought used in 2010. changed oil, ran great. use it at the four wheeler park in March and again in december for 3 weeks hunting. Parks in the garage and get run .3 miles down the bayou and back once every 3 weeks. have marine grade Stabil in the gas.

Here the situatiuon. about a month ago i took it out for the bayou run and it took its time getting up to speed then aroung 15 mph the normal power kicked in. when I stopped to turn around the idle was really rough. drove slowly back (5 or 6 mph) and it backfired, ran faster and power returned. have continued to run it for longer periods and idle does eventually get better but its still a little rough and has a noticeable decrease in power at slow speeds. Hunting trip coming up in 2 months and dont want to be stuck 2 miles out in the frozen woods or get there a 430 am and have to struggle for an hour to start it like i used to have to do on my old honda. (so glad i got rid of that wheeler) Any suggestions on where to start?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
common ailments

As a side note, I see that a lot of you guys have replaced the A arm bushings. I like trails, sometimes pretty fast, cross water mud when I have to but dont go looking for it. What are the most common parts to fail or issues to have with this machine?
 

·
Registered
Joined
·
220 Posts
If I was you I'd start with the coils make sure there connections are clean then spark plugs and then clean all the plugs under the seat for the computers and stuff, all machines need a little bit of time to warm up,
 

·
Registered
Joined
·
220 Posts
I don't know what is in fuel stabalizer but I'd problebly run that competly through the tank and see if it runs better
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Stabil is supposed to wet the gas and keep the ethanol deposits from clogging everything up. Most of it is out now. maybe out to drain the tank and put some fresh gas and maybe a little sea foam in with it. wondering if there is a fuel filter on this machine? could be on the pump since it its injected.
 

·
Registered
Joined
·
220 Posts
I'm pretty sure its in the tank but if you still got lots of topend I doubt that it would be a clogged filter cause it would be fine at idle and slow speed but sputter at higher speed
 
1 - 6 of 6 Posts
Top