Mud in My Blood Forum banner

61 - 80 of 102 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #62
It just seems the teeth sheared off the gears, and then wrecked havoc inside the housing.
 

·
Administrator
Joined
·
15,498 Posts
hauled some logs.
 
  • Like
Reactions: Slydog

·
Registered
Joined
·
236 Posts
Got my clutch cover onlast night. Was going to fire it up before i put the plastic back on but battery was dead. Probably left radio on
 

·
Registered
Joined
·
191 Posts
Discussion Starter #68
Ordered a brand new complete carburetor for my new-to-me 2001 Honda Foreman 450ES. Installed a 2" lift kit on it from HighLifter. Put on 27" ITP Blackwaters. Looking good. Not running great.
 

·
Administrator
Joined
·
15,498 Posts
Rode it around the property. Lol.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
191 Posts
Discussion Starter #71
I just bought a new, OEM carb for it. I figured that with a completely new carb, that should eliminate any problems at all.
 

·
Registered
Joined
·
191 Posts
Discussion Starter #72
Greased all fittings on the Polaris. Put too much grease in one of the ball joints, and blew out the rubber boot. Grrrrrr.
 

·
Administrator
Joined
·
15,498 Posts
fixed the little wires that keep the front box lid from flipping too far open. AGAIN....... for like the 3rd time.
 

·
Registered
Joined
·
236 Posts
Finally got around to tearing down my Extra front dif to see what was broken. When i removed driver's side axle i noticed. Clip on the end of the axle was missing . guess po tryed to put in a new axle.
Found the clip and some spider gear teeth.
Ring and pinion look perfect
23410
23411
23412
 

·
Registered
Joined
·
191 Posts
Discussion Starter #80
Dropped of the Honda at the repair shop. Got to get it perfect before Muddy Valentine, and I just dont have time to work on it. So, I bit the bullet, and gave it to someone else to fix.
 
61 - 80 of 102 Posts
Top