Mud in My Blood Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Title says it all, Trying to figure out what is the deal. So during Hurricane Florence in N.C. i was unable to take My 2015 Sportsman XP 1000. I never thought it was going to flood but infact it did. The garage took over5 ft of water. I even had to take a jon boat to get back to my house in NC. So when i came back the atv was ontop of my pressure washer. I was unable to stay and correct any of the damages, until about a week later. Long story short; try to turn over and nothing no light displayed nothing.The ATV will not crank it has been drying out in garage with dehumidifiers. I have changed fluids and recharged battery for up to 8 hrs on slow charge but have not had battery tested. Just trying to get an overall consenus on what might be wrong/need to be replaced. I'm leaning on taking to the dealer but seeing if i can manage to figure/repair on my own. Has not been turned over/ ran. Unpluged all connectors cleaned them out. Fuses, and relayslook good. Thanx in advance.
 

Attachments

·
Moderator
Joined
·
7,400 Posts
Well, for starters, every non-water tight electrical connection will be wet and corroded by now along with the starter motor. And the battery is probably shot. Also the residual moisture in the engine...and yes, there will be...is sitting there rusting steel parts line bearings, pumps, gears..ect. At least it was not run and you drained it without turning it over. That may have saves it. But it needs to run and get another change asap so..get to those electrical inspections...and don't forget the bar and ignition switches. Get a few cans of spray contact cleaner and either start from the battery and work out or the bars down. Good luck. Hope you can save it.
 

·
Administrator
Joined
·
15,372 Posts
That sucks... You have insurance on it? If not, homeowners may cover it if it's a loss, since it was in the garage.
 

·
Registered
Joined
·
1 Posts
Discussion Starter #4
Well, for starters, every non-water tight electrical connection will be wet and corroded by now along with the starter motor. And the battery is probably shot. Also the residual moisture in the engine...and yes, there will be...is sitting there rusting steel parts line bearings, pumps, gears..ect. At least it was not run and you drained it without turning it over. That may have saves it. But it needs to run and get another change asap so..get to those electrical inspections...and don't forget the bar and ignition switches. Get a few cans of spray contact cleaner and either start from the battery and work out or the bars down. Good luck. Hope you can save it.
Hey Seriously thanx for the advice and info. Tested the battery and i was amazed that it registered 12.8/9 v and 415 CCa. I think i am going to try to replace all of the fuses and relays. I am leaning on just taking to the dealer they said just to diagnose 100$. Dont know if it was good or bad but i took all of the relays out and fuses fron the front and vacuumed the water out then sprayed wd 40 let sit for about 5 m and then sucked out again and let dry. That was when i changed fluids.
 

·
Registered
Joined
·
1 Posts
Discussion Starter #5
That sucks... You have insurance on it? If not, homeowners may cover it if it's a loss, since it was in the garage.
No no flood insurance. I was told and verified through Fema Flood map that i was not in a flood plaine/zone.
When i bought the house four years ago. Matthew came through and i did not get anything. So the rest is history. Maybe i am wrong but you think they would cover it because it is in the garage or you saying that if i had flood insurance?
 

·
Registered
Joined
·
5 Posts
If you didn't have insurance on your ATV you will likely be out of luck. I learned the hard way a few years ago with dirt bikes. Stole from my garage. Found out home owners does not cover any motor vehicle, other than maybe a lawn mower.



So now I have every toy on a policy, bikes, quad, sled... It isn't that expensive.



Maybe if you can prove that it was used for property maintenance, you might find a loophole. But if your home owners isn't covering the flood, then you probably aren't going to get the quad covered either.


Sucks.


--- Something fishy (I think) about this whole flood insurance thing. I tried to get flood insurance. You just never know. Even though I don't live near a stream or anything, the water table is high enough, I feel like a freak rain storm could flood our basement pretty easily. But because we don't live in a flood zone, we can't get that insurance. Seems strange to me, that if I'm willing to give the insurance company money for something they think is unlikely to happen, why don't they just take the money?
 

·
Administrator
Joined
·
15,372 Posts
yeah flood insurance is a crazy thing...

You can live somewhere 40 years and it not be in a flood plane and then all of a sudden they deem that it is, and you have to get flood insurance...

happened to someone down the road from us, we looked at their house when it was for sale, and found out it had flip flopped several times over the years, so we passed on it.
 

·
Registered
Joined
·
1 Posts
Discussion Starter #8
Update

So looking for suggestions / advice. Since my last post i dropped off my XP to a dealer in Wilmington NC (Wilmington Power sports). They diagnosed. Finally got a call back today (they have been backed up). They are saying that i need a new ECM. They cannot guarantee that this will fix the problem but say it is a start. They said they had it running about three weeks ago and that they were going to let the harness dry out as it was throwing codes. Got a call today and they mentioned the ECM and that some pins were broke / corroded and it needed to be replaced. They quoted me with labor 2200$( 1200 for part) the rest for labor. Then they said if that does not fix they would then replace EPS if needed (for a total of 4400) They also said they could just order the parts for me. So far i am on the hook for the diagnosis. I was completely shocked. I am thinking about doing this on my own and am wondering if anybody had any experience. A quick search on the web and i found some ECMs for way lmean way less but do not have the actual part number.
Much appreciation in advance!:surprise:
 

·
Moderator
Joined
·
7,400 Posts
ECMs and other boxes are water tight as well as their connections. I would want to see exactly what they are talking about and WOW..they are sticking it to you for what they are and have done. The machine isn't worth all that and you can get your own ECU/M and other parts like that off ebay used or even new for much less. I would be more concerned about the engine being under water and what it's done to it internally first. The harness and other components are just plug-n-play work but the engine is where the real money issues could be.
 

·
Registered
Joined
·
1 Posts
Discussion Starter #10
ECMs and other boxes are water tight as well as their connections. I would want to see exactly what they are talking about and WOW..they are sticking it to you for what they are and have done. The machine isn't worth all that and you can get your own ECU/M and other parts like that off ebay used or even new for much less. I would be more concerned about the engine being under water and what it's done to it internally first. The harness and other components are just plug-n-play work but the engine is where the real money issues could be.

Thanx for the input. that is the same thing i thought about the ECM. I mean it sat in water i just don't know how long it did.could have been two days. Wilmington Power sports seemed like a str8 up shop but when i heard the estomate i was like????? I am going to pick it up; get them to give me all the part numbers (since i paid for the diagnostic) and take a shoot at doing it my self.
 

·
Registered
Joined
·
1 Posts
Discussion Starter #11
well i picked up the XP. I decided on doing it myself found a used ECU/ECM on ebay for $125 from powers sports nation. So that will be my first go. I however have no clue on where to look for the ECU/ECM, so if one of you kind folks can point me in a direction that would be great. They asked me if i wanted them to put the plastics that they had taken off back on and i said no. I retrieved all of my plastics and hardware for said plastics. The part should be in sometime next week. I will upload the pics of there work order , codes that flashed/came up, ECU/ECM to see what you guys think and suggest by the end of the week. I have the old ECU/ECM and they pointed out the pins that were broke and corroded. They had the parts that needed to be replaced as the ECU/ECM, main harness (because they said the pins was still inserted that broke off from the ECM/ECU. They also stated they have tried in the past to get the pins out but were unsuccessful. They however did not mention if they tried mine), and possibly the ASM-Power Steering. Thanx in Advance
 

·
Moderator
Joined
·
7,400 Posts
I for one would like to know just how those pins bent and broke off just sitting there. Clearly they had some kid working on it. The pins are straight so if you can get ahold of them with anything they will slide straight out...and I suggest getting some spray contact cleaner and soak the F'k out of them first and letting them sit a while, then one more soak and flush before trying.
 

·
Registered
Joined
·
1 Posts
Discussion Starter #13
Thanx for the input NMKawierider. Are you saying to soak the pins on the new ECM/ECU? Yea that is the same thing i thought about like how did the pins break? I will have pics uploaded tomorrow.T everyone on here I appreciate all of your insight!

I for one would like to know just how those pins bent and broke off just sitting there. Clearly they had some kid working on it. The pins are straight so if you can get ahold of them with anything they will slide straight out...and I suggest getting some spray contact cleaner and soak the F'k out of them first and letting them sit a while, then one more soak and flush before trying.
 

·
Moderator
Joined
·
7,400 Posts
Thanx for the input NMKawierider. Are you saying to soak the pins on the new ECM/ECU? Yea that is the same thing i thought about like how did the pins break? I will have pics uploaded tomorrow.T everyone on here I appreciate all of your insight!
Oh...sh*t..if the pins are on the harness side..you have a problem. Can't make connections without pins. But if the harness has the female side, the broken pins have to come out so the new ECM can plug in. Looks like at least some are this way.



https://www.partzilla.com/product/polaris/4012838
 

·
Registered
Joined
·
1 Posts
Discussion Starter #18
New/used ecm. Hello all here it is shipped fast received it last night. Anybody have any suggestion on what to clean it with? Also any body possibly have a link/service manual file? Lastly suggestion on location and how if able to get stuck pin out of harness? much appreciated
 

Attachments

·
Registered
Joined
·
1 Posts
Discussion Starter #20
Thanx alot for the guidance. I will keep ya'll posted. I finally got some days off. So i get to give it a go.

Clean outside with any Brake parts cleaning spray like Brakeclean. Clean contact areas with any contact cleaner. Soak broken pins and receivers first with PB or WD. Then work out with precision tools . Then flush-clean with contact spray
 
1 - 20 of 20 Posts
Top